题目:LightOJ 1422 Halloween Costumes
Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it’s Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of ‘Chinese Postman’.
Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn’t like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).
Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.
Input
Input starts with an integer T (≤ 200), denoting the number of test cases.
Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.
Output
For each case, print the case number and the minimum number of required costumes.
Sample Input
2
4
1 2 1 2
7
1 2 1 1 3 2 1
Sample Output
Case 1: 3
Case 2: 4
题意:
给你n天分别要穿的衣服类型,可以套着穿(不加件数),但是一旦脱下来再穿就要多准备一件,问这n天要准备几件衣服。
分析:
当前的结果对后来造成了影响,典型的DP。考虑衣服的重复穿情况:
a[i]=a[k]:dp[i][j]=dp[i][k]+dp[k+1][j]−1;(相当于第i件衣服一直套在身上,在k位置重复利用)
a
[
i
]
=
a
[
k
]
:
d
p
[
i
]
[
j
]
=
d
p
[
i
]
[
k
]
+
d
p
[
k
+
1
]
[
j
]
−
1
;
(
相
当
于
第
i
件
衣
服
一
直
套
在
身
上
,
在
k
位
置
重
复
利
用
)
a[i]!=a[k]:dp[i][j]=dp[i][k]+dp[k+1][j];
a
[
i
]
!
=
a
[
k
]
:
d
p
[
i
]
[
j
]
=
d
p
[
i
]
[
k
]
+
d
p
[
k
+
1
]
[
j
]
;
这道题的常规思路:枚举长度和起点,dp[i][j]:表示区间[i,j]使用的最少衣服,找到转移点然后区间合并;
这
道
题
的
常
规
思
路
:
枚
举
长
度
和
起
点
,
d
p
[
i
]
[
j
]
:
表
示
区
间
[
i
,
j
]
使
用
的
最
少
衣
服
,
找
到
转
移
点
然
后
区
间
合
并
;
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long LL;
const int MAXN = 105;
int dp[MAXN][MAXN], a[MAXN];
char str[MAXN];
int main() {
int T, n;
scanf("%d", &T);
while(T--) {
scanf("%d", &n);
for(int i = 1; i <= n; i++) {
scanf("%d", &a[i]);
dp[i][i] = 1;
}
for(int L = 2; L <= n; ++L) {
for(int i = 1; i <= n - L + 1; ++i) {
int j = i + L - 1;
dp[i][j] = dp[i + 1][j] + 1;
for(int k = i + 1; k <= j; ++k) {
if(a[i] == a[k]) //状态转移点:第i件衣服重复利用
dp[i][j] = min(dp[i][j], dp[i][k - 1] + dp[k][j] - 1);
else dp[i][j] = min(dp[i][j], dp[i][k] + dp[k + 1][j]);
}
}
}
static int p = 1;
printf("Case %d: %d\n", p++, dp[1][n]);
}
return 0;
}