HDU 6383 p1m2【二分】

Problem Description
度度熊很喜欢数组!!
我们称一个整数数组为稳定的,若且唯若其同时符合以下两个条件:
1. 数组里面的元素都是非负整数。
2. 数组里面最大的元素跟最小的元素的差值不超过 1。
举例而言,[1,2,1,2] 是稳定的,而 [−1,0,−1] 跟 [1,2,3] 都不是。
现在,定义一个在整数数组进行的操作:
* 选择数组中两个不同的元素 a 以及 b,将 a 减去 2,以及将 b 加上 1。
举例而言,[1,2,3] 经过一次操作后,有可能变为 [−1,2,4] 或 [2,2,1]。
现在给定一个整数数组,在任意进行操作后,请问在所有可能达到的稳定数组中,拥有最大的『数组中的最小值』的那些数组,此值是多少呢?
Input
输入的第一行有一个正整数 T,代表接下来有几组测试数据。
对于每组测试数据:
第一行有一个正整数 N。
接下来的一行有 N 个非负整数 xi,代表给定的数组.
* 1≤N≤3×105
* 0≤xi≤108
* 1≤T≤18
* 至多 1 组测试数据中的 N>30000
Output
对于每一组测试数据,请依序各自在一行内输出一个整数,代表可能到达的平衡状态中最大的『数组中的最小值』,如果无法达成平衡状态,则输出 −1。
Sample Input
2
3
1 2 4
2
0 100000000
Sample Output
2
33333333

分析:二分那个最小值,用三个变量保存上升的次数,下降的次数,可以上升可以下降的次数;

#include <bits/stdc++.h>
using namespace std;
#define met(s) memset(s, 0, sizeof(s))
#define rep(i, a, b) for(int i = a; i <= b; ++i)
typedef long long LL;
typedef unsigned long long ull;
typedef pair<int, int> pii;
const int INF = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const int MAXN = 3e5 + 10;
int a[MAXN], n;

bool judge(int x) {
    LL res = 0, ans = 0, cnt = 0;
    for(int i = 1; i <= n; ++i) {
        if(a[i] == x) ans++;
        else if(a[i] < x) {
            cnt = cnt + x - a[i];
            ans++;
        }
        else if(a[i] - x >= 2) {
            res = res + int((a[i] - x) / 2);
            if((a[i] - x) % 2 == 0) ans++;
        }
    }
    //printf("## %4lld %9lld %4lld %9d\n", res, cnt, ans, x);
    if(ans + cnt <= res) return true;
    return false;
}

bool check(int x) {
    LL res = 0, ans = 0, cnt = 0;
    for(int i = 1; i <= n; ++i) {
        if(a[i] == x) ans++;
        else if(a[i] < x) {
            cnt = cnt + x - a[i];
            ans++;
        }
        else if(a[i] - x >= 2) {
            res = res + int((a[i] - x) / 2);
            if((a[i] - x) % 2 == 0) ans++;
        }
    }
    //printf("## %4d %9d %4d %9d\n", res, cnt, ans, x);
    if(res >= cnt) {
        if(ans + cnt > res) return true;
        return false;
    }
    return false;
}

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        for(int i = 1; i <= n; ++i) scanf("%d", &a[i]);
        int L = 0, R = mod;
        while(R - L >= 0) {
            int mid = (R + L) >> 1;
            if(judge(mid)) L = mid + 1;
            else R = mid - 1;
        }
        //printf("## %d %d\n", L, R);
        bool flag1 = check(L);
        bool flag2 = check(R);
        if(flag1) printf("%d\n", L);
        else if(flag2) printf("%d\n", R);
        else puts("-1");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值