HDU - 1969(分蛋糕)【最大化平均值】

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.  

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

题意:给出n个蛋糕的半径,还有m+1个人,每个人的馅饼必须是整块且相等的,蛋糕可以切开分但不能拼接,求分到的最大块蛋糕(高是1,只考虑面积即可)。

思路:(贪心 + 二分)

第一步:先用贪心的方法找最优解,然后才能采用二分搜索出答案;

第二步:(贪心找最优解)最大的蛋糕可能会切开分,小的蛋糕可能不会去分,找出最优的mid大的蛋糕,并且 >=m+1 整数块;

第三步:二分搜索出满足所有条件的最优的mid,输出即可;

#include<stdio.h>
#include<math.h> 
#include<algorithm>
using namespace std;
#include<string.h>
#define pi acos(-1.0)
double n,m;
double a[10010];//记录每一块大小; 
int f(double k)
{
	int ans=0;
	for(int i=0;i<n;i++)
	{
		ans+=int(a[i]/k);//int(a[i]/k)代表a[i]块蛋糕能切出多少块k,ans用来计算总共有多少块k; 
		if(ans>=m)//判断是否足够m个人分; 
		    return true;
	}
	return false;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf %lf",&n,&m);
		m++;//加上主人; 
		double res=0.0,v;
		for(int i=0;i<n;i++)
		{
			scanf("%lf",&v);
			a[i]=v*v*pi; 
			res=max(res,a[i]);//找出最大块的蛋糕,二分中的right; 
		}
		double l,r,mid;
		l=0.0,r=res;
		while(r-l>=1e-6)//套用二分公式; 
		{
			mid=(l+r)/2;
			if(f(mid))
			{
				l=mid;//仅是满足条件的蛋糕块,直到循环结束,二分出最优mid; 
			}
			else r=mid;
		}
		printf("%.4lf\n",l);
	}
	return 0;
}


  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值