pat考试-1136

  1. A Delayed Palindrome (20)
    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue
    Consider a positive integer N written in standard notation with k+1 digits ai as ak…a1a0 with 0 <= ai < 10 for all i and ak > 0. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number)

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line “C is a palindromic number.”; or if a palindromic number cannot be found in 10 iterations, print “Not found in 10 iterations.” instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

这道题一上场看到就想用java写,但是上了Java又不会String的翻转方法(用StringBuffer),这是很奔溃,只能去写c++的模拟高精度了,嗨,写的时候还老出bug,写完一个小时过去了,还有几个测试样例过不去,没想到,如果他刚输入就是回文,就不用进循环了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 1005;
int add(char a[],char b[],int c[])
{
    int m = strlen(a);
    /*for(int i = 0;i <= m;++i)
    {
        printf("%d ",c[i]);
    }
    cout << endl;*/
    for(int i = 0;i < m;++i)
    {
        int k = c[i];
        //cout << c[i] << endl;
        c[i] = ((a[i] - '0') + (b[i] - '0') + c[i]) % 10;
        //cout << a[i] << " " << b[i] << " " << c[i] << endl;
        if((a[i] - '0') + (b[i] - '0') + k >= 10)
            c[i + 1] += 1;
    }
    /*for(int i = 0;i <= m;++i)
    {
        printf("%d ",c[i]);
    }
    cout << endl;*/
    if(c[m] != 0){
        return m + 1;
    }
    else{
        return m;
    }
}
void print(int c[],int m)
{
    for(int i = 0;i < m;++i)
    {
        printf("%d",c[i]);
    }
}
bool judge(int c[],int m)
{
    for(int i = 0;i <= m / 2;++i)
    {
        if(c[i] != c[m - 1 - i]){
            return false;
        }
    }
    return true;
}
void reverse(int c[],int m)
{
    int a[N];
    for(int i = 0;i < m;++i)
    {
        a[m - 1 - i] = c[i];
    }
    for(int i = 0;i < m;++i)
    {
        c[i] = a[i];
    }
}
int main()
{
    char a[N],b[N];
    int e[N];
    scanf("%s",a);
    int k = 0;
    for(int i = strlen(a) - 1;i >= 0;--i)
    {
        b[k++] = a[i];
    }
    printf("%s\n",b);
    int i;
    for(int i = 0;i < strlen(a);++i)
    {
        e[i] = a[i] - '0';
    }
    int m = strlen(a);
    if(judge(e,m)){
        print(e,m);
        printf(" is a palindromic number.\n");
        return 0;
    }
    for(i = 0;i < 10;++i){
    memset(e,0,sizeof(e));
    m = add(a,b,e);
    reverse(e,m);
    printf("%s + %s = ",a,b);
    print(e,m);
    cout << endl;
    if(judge(e,m)){
            print(e,m);
        printf(" is a palindromic number.\n");
        break;
    }
    int k = 0;
    for(int i = 0;i < m; ++i)
    {
        a[i] = e[i] + '0';
    }
    a[m] = '\0';
    for(int i = m - 1;i >= 0;--i)
    {
        b[i] = a[m - 1 - i];
    }
    /*for(int i = 0;i < m;++i)
    {
        printf("%d ",e[i]);
    }
    cout << endl;*/
    }
    if(i == 10){
        printf("Not found in 10 iterations.\n");
    }
    return 0;
}*/

下来又写了java版的

import java.util.Scanner;
import java.math.BigInteger;
public class Main {
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner in = new Scanner(System.in);
        BigInteger a = in.nextBigInteger();
        String s = a.toString();
        StringBuffer s1 = new StringBuffer(s);
        if(s.equals(s1.reverse().toString())) {
            System.out.println(s + " is a palindromic number.");
            return ;
        }
        int i;
        for(i = 0;i < 10;++i)
        {
            String s2 = a.toString();
            StringBuffer s3 = new StringBuffer(s2);
            BigInteger b = new BigInteger(s3.reverse().toString());
            //System.out.println(b.toString());
            BigInteger c = new BigInteger("0");
            c = a.add(b);
            System.out.println(s2 + " + " + b.toString() + " = " + c.toString());
            StringBuffer m = new StringBuffer(c.toString());
            if(c.toString().equals(m.reverse().toString())) {
                System.out.println(c.toString() + " is a palindromic number.");
                break;
            }
            a = c;
        }
        if(i == 10) {
            System.out.println("Not found in 10 iterations.");
        }
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值