尺取法poj3061

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18567 Accepted: 7937
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output

2
3
Source
应该看到规律了吧 每次sum加到大于等于15的位置,然后从左边舍弃一个,判断当前sum的值,如果小于15就继续像妹子一样向前+一个数,取最短。否则就继续舍弃,总之每个sum的是满足条件的 如果sum不满足 就退出循环。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define N 100005
#define MAXN 0x3f3f3f3f
int a[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,s;
        scanf("%d %d",&n,&s);
        for(int i = 0;i < n;++i)
        {
            scanf("%d",&a[i]);
        }
        int l = 0,r = -1,res = MAXN;
        int sum = 0;
        while(true)
        {
            while(sum < s && r < n)
            {
                sum += a[r];
                r++;
            }
            if(sum < s)
                break;
            res = min(res,r - l);
            sum -= a[l++];
            //cout << r << " " << l << " " << sum << endl;
        }
        if(res != MAXN){
            printf("%d\n",res);
        }
        else{
            printf("0\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值