HDU-1854 Q-Sequence

HDU-1854 Q-Sequence
Time Limit: 1000 ms / Memory Limit: 65535 kb
Description

A Q-sequence is defined as:

Q-Seq := 0 or
Q-Seq := Q-seq Q-seq 1

That is to say a Q-Sequence is a single ‘0’ or two Q-Sequences followed by an ‘1’.

Given a sequence of ‘0’s and ‘1’s, you are to determine whether it is a Q-Sequence.

Input

The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’s and ‘0’s. The maximum length of the sequence is 1000.

Output

The output contain n lines, print “Yes” if it is a Q-sequence, otherwise print “No”.

Sample Input

3
0010011
0101
00011
Sample Output

Yes
No
Yes
Source

HDU 2007 Programming Contest - Final

原先没读懂题,Q为0,我理解成多个0了,看1就可以了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 0;i < n;++i)
    {
        string s;
        cin >> s;
        bool flag = false;
        int num = 0;
        int len = s.size();
        for(int i = 0;i < len;++i)
        {
            if(s[i] == '0')
                num++;
            if(s[i] == '1'){
                if(num >= 2){
                    num -= 1;
                }
                else{
                    flag = true;
                    break;
                }
            }
        }
        if(!flag){
            printf("Yes\n");
        }
        else{
            printf("No\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值