最短路-------C - Heavy Transportation

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4

。。。。其实没读懂题,还以为还是求1到达n的所有路径中最大边的最小值。。。。但不是,这道题是运送货物,是承重,应该是路径里的最小的承重,因为只有最小承重才能通过这条路径运过来,然后再找出最大值。。。。
一直wa,原来理解错题意了
接下来是用spfa变形处理

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
const double eps = 1e-8;
const double PI = acos(-1);
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 1005;

int dis[N];
bool vis[N];
int mk[N][N];
int t,n,m;

void spfa()
{
    memset(vis,false,sizeof(vis));
    memset(dis,0,sizeof(dis));
    queue<int>que;
    vis[1] = true;
    dis[1] = inf;
    que.push(1);
    while(!que.empty())
    {
        int tmp = que.front();
        que.pop();
        vis[tmp] = false;
        for(int i = 1;i <= n;++i){
            //cout << tmp << " " << i << endl;
            //cout << dis[tmp] << " " << mk[tmp][i] << " " << dis[i] << endl;
            if(mk[tmp][i] != -1 && min(mk[tmp][i],dis[tmp]) > dis[i]){
                dis[i] = min(mk[tmp][i],dis[tmp]);
                if(!vis[i]){
                    vis[i] = true;
                    que.push(i);
                }
            }
        }
    }
}

int main()
{
    int cnt = 0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        cnt++;
        memset(mk,-1,sizeof(mk));
        for(int i = 1;i <= m;++i){
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            if(mk[a][b] == -1 || c < mk[a][b]){
                mk[a][b] = mk[b][a] = c;
            }
        }
        spfa();
        printf("Scenario #%d:\n",cnt);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值