线段树-----F - Count the Colors

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can’t be seen, you shouldn’t print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1
1 1

0 2
1 1

涉及到区间覆盖,区间染色,基本可以用线段树解决,其实模拟直接做就行,因为10^6不会超,用线段树就会快很多。。。
先将每个区间赋予颜色,然后再找颜色段

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 8000 + 5;

int tree[N << 2];
int num[N];
int res[N];
int k;

void pushdown(int root)
{
    if(tree[root] != -1){
        tree[root * 2 + 1] = tree[root];
        tree[root * 2 + 2] = tree[root];
        tree[root] = -1;
    }
}

void update(int root,int l,int r,int pl,int pr,int val)
{
    if(r < pl || l > pr){
        return ;
    }
    if(l >= pl && r <= pr){
        tree[root] = val;
        return ;
    }
    pushdown(root);
    int mid = (l + r) / 2;
    if(pl <= mid){
        update(root * 2 + 1,l,mid,pl,pr,val);
    }
    if(pr > mid){
        update(root * 2 + 2,mid + 1,r,pl,pr,val);
    }
}

void query(int root,int l,int r,int pl,int pr)
{
    if(l == r){
        res[k++] = tree[root];
        return ;
    }
    pushdown(root);
    int mid = (l + r) / 2;
    if(pl <= mid){
        query(root * 2 + 1,l,mid,pl,pr);
    }
    if(pr > mid){
        query(root * 2 + 2,mid + 1,r,pl,pr);
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(tree,-1,sizeof(tree));
        memset(res,-1,sizeof(res));
        memset(num,0,sizeof(num));
        for(int i = 0;i < n;++i){
            int x,y,z;
            scanf("%d %d %d",&x,&y,&z);
            update(1,1,8000,x + 1,y,z);
        }
        k = 0;
        query(1,1,8000,1,8000);
        for(int i = 0;i < k;)
        {
            if(res[i] == -1){
                i++;
                continue;
            }
            num[res[i]]++;
            int j;
            for(j = i + 1;j < k;++j){
                if(res[j] != res[i] || res[j] == -1){
                    break;
                }
            }
            i = j;
        }
        for(int i = 0;i <= 8000;++i){
            if(num[i] != 0){
                printf("%d %d\n",i,num[i]);
            }
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值