A1004 Counting Leaves映射秒解

pat甲级A1004一种基于map的解法,没有采用BFS或者DFS,而是采用了映射关系。顺利AC且代码较为简洁。


一、原题

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

二、大意

第一行有两个数据,一个是总结点数N,一个非叶结点数M
接下来就是对m个非叶结点具体信息,01是根节点,然后是孩子结点的个数,接下来才是孩子结点的编号;
问题:求每一层的叶子结点数量。

三、思路

利用map映射关系保存结点信息

map<string,vector<string>> ma;//节点信息
ma[node].push_back(child);//插入操作

利用队列进行层序遍历
因为它要按层输出,所以得记录当前层剩余的结点个数,除此之外还得记录下一层的个数,已经要要输出的count;

注意点:
1、数据量较小n≤100,这种情况基本不会超时,所以直接建立string的映射关系,从而避免很多麻烦
2、count不能直接输出,因为无法知道自己遍历到哪一层,从而无法判断是否需要继续输出空格。

四、具体实现

代码如下:

#include<vector>
#include<iostream>
#include<queue>
#include<map>
#include<set> 
using namespace std;

int main(){
	int M,NUM;
	cin>>M>>NUM;
	//构建map映射 
	map<string,vector<string>> ma;
	string ci_1,ci_2;
	int ci_n;
	for(int i =0;i<NUM;i++){
		cin>>ci_1;
		scanf("%d",&ci_n);
		for(int j=0;j<ci_n;j++){
			cin>>ci_2;
			ma[ci_1].push_back(ci_2);
		}
	}
	
	queue<string> qu;
	qu.push("01");
	//cnow记录当前层结点数量,cnext记录下一层 
	int cnow=1;
	int cnext = 0;
	int count=0;
	string now;//现在访问的节点 
	vector<int> veans;
	while(qu.empty()!=true){
		now = qu.front(); 
		qu.pop();
		cnow--;
		cnext+=ma[now].size();
		//没有孩子的节点; 
		if(ma[now].size()==0)	count++; 
		for(int i=0;i<ma[now].size();i++){
			qu.push(ma[now][i]);
		}
		if(cnow==0){
			cnow = cnext;
			cnext = 0;
			veans.push_back(count);
			count=0;
		}		
	}
	for(int i=0;i<veans.size();i++){
		printf("%d",veans[i]);
		if(i!=veans.size()-1)	printf(" ");
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
你可以这样解析出 map 中的 fullDocument 中的 OwnerID、name、QuotaSize: ``` package main import ( "fmt" "reflect" ) func main() { m := map[string]interface{}{ "_id": map[string]interface{}{ "_data": "8263B4EB63000000062B022C0100296E5A1004C3E4524B77B64630AC204C7469FAED7F46645F6964006463B4EB636EBBDB249F2ED2770004", }, "clusterTime": map[string]interface{}{ "1672801123": 6, }, "documentKey": map[string]interface{}{ "_id": "ObjectID(\"63b4eb636ebbdb249f2ed277\")", }, "fullDocument": map[string]interface{}{ "OwnerID": 123, "QuotaSize": 104857600, "_id": "ObjectID(\"63b4eb636ebbdb249f2ed277\")", "directory": "/buckets", "name": "123_test1", }, "ns": map[string]interface{}{ "coll": "UserQuotaConfig", "db": "filer3", }, "operationType": "insert", "wallTime": 1672801123879, } // 取出 fullDocument fullDocument, ok := m["fullDocument"].(map[string]interface{}) if !ok { fmt.Println("fullDocument not found") return } // 取出 OwnerID OwnerID, ok := fullDocument["OwnerID"].(int) if !ok { fmt.Println("OwnerID not found") return } fmt.Println("OwnerID:", OwnerID) // 取出 name name, ok := fullDocument["name"].(string) if !ok { fmt.Println("name not found") return } fmt.Println("name:", name) // 取出 QuotaSize QuotaSize, ok := fullDocument["QuotaSize"].(int) if !ok { fmt.Println("QuotaSize not found") return } fmt.Println("QuotaSize:", QuotaSize) } ``` 在这个例子中,我们首先将 map 赋值给了变量 m。然后使用类型断言取出了 fullDocument 并将其赋
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值