Wormholes

  点击打开链接

While  exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

就是来判断负数环。也就是回到了这个点之前的存在。

注意这个边的申请多少个,正反。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define BIG  10000
#define bug(x) printf("%d***\n",x)
typedef long long ll;
using namespace std;
const int maxn=610;
const int maxm=3000;
const int inf=0x3f3f3f3f;
/*
重做了一遍,发现已经凉了一片
spfa用队列,不用优先队列
还有就是次数的问题:
我们都知道spfa算法是对bellman算法的优化,
那么如何用spfa算法来判断负权回路呢?我们考虑一个节点入队的条件是什么,
只有那些在前一遍松弛中改变了距离估计值的点,才可能引起他们的邻接点的距离估计值的改变。
因此,用一个先进先出的队列来存放被成功松弛的顶点。同样,我们有这样的定理:“两点间如果有最短路,
那么每个结点最多经过一次。也就是说,这条路不超过n-1条边。”
(如果一个结点经过了两次,那么我们走了一个圈。如果这个圈的权为正,显然不划算;如果是负圈,
那么最短路不存在;如果是零圈,去掉不影响最优值)。也就是说,每个点最多入队n-1次
(这里比较难理解,需要仔细体会,n-1只是一种最坏情况,实际中,这样会很大程度上影响程序的效率)。 
*/
int n,m,w;
struct Edge{
	int v,nt;
	int w;
}edge[maxm*2];
int head[maxm*2];
int cnt=0;
void add_edge(int u,int v,int w){
	edge[cnt].nt=head[u];
	edge[cnt].v=v;
	edge[cnt].w=w;
	head[u]=cnt++;
}

int vis[maxn],tim[maxn];
int dis[maxn];
int spfa(int st){
	int now;
	memset(vis,0,sizeof(vis));
	memset(tim,0,sizeof(tim));
	memset(dis,inf,sizeof(dis));
	vis[st]=1,dis[st]=0,tim[st]=1;
	queue<int> q; 
	q.push(st);
	while(!q.empty()){
		now=q.front();
		q.pop();
		vis[now]=0;
		for(int i=head[now];i!=-1;i=edge[i].nt){
			int v=edge[i].v,w=edge[i].w;
			if(dis[v]>dis[now]+w){
				dis[v]=dis[now]+w;
				if(!vis[v]){
					q.push(v);
					vis[v]=1,tim[v]++;
					if(tim[v]>=n) return 1;
				}
			}
		}
	}	
	return 0;
}

int main() {
	int T;
	scanf("%d",&T);
	while(T--){
		cnt=0;
		memset(head,-1,sizeof(head));
		scanf("%d %d %d",&n,&m,&w);
		for(int i=1;i<=m;i++){
			int a,b,v;
			scanf("%d %d %d",&a,&b,&v);
			add_edge(a,b,v);
			add_edge(b,a,v);
		}
		for(int i=1;i<=w;i++){
			int a,b,v;
			scanf("%d %d %d",&a,&b,&v);
			v=v*(-1);
			add_edge(a,b,v);
		}
		int flag=0;
		for(int i=1;i<=n;i++){
			if(spfa(i)){
				flag=1;break;
			}		
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值