Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=110;
char str[maxn];
int dp[maxn][maxn];
/*
 状态转移的方向,应该是在已经求出来的子状态,往上递推
 我们枚举 起点 终点像是 (a),但是起点和终点一定就是最佳匹配么,
 不一定,有可能是ab类型的,所以我们需要找到i-j的最大值
*/
int main()
{
	while(~scanf("%s",&str)) {
		if(str[0]=='e') break;
		memset(dp,0,sizeof(dp));
		int len=strlen(str);
		for(int i=len-1; i>=0; i--) {
			for(int j=i+1; j<len; j++) {
				if(str[i]=='('&&str[j]==')'||str[i]=='['&&str[j]==']')
					dp[i][j] =dp[i+1][j-1]+2;
				for(int k=i; k<=j; k++)
					dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);
			}
		}
		printf("%d\n",dp[0][len-1]);
	}
	return 0;
}
/*
错误的做法
想着匹配一个是一个
[(])这样的例子就错了
还有就是那个判断的语句,错了好几遍
while((j>=0&&str[j]!='(')||(str[j]=='('&&vis[j])) {	j--;} 
还是基础不太牢固 
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值