Brackets(区间DP)

102 篇文章 0 订阅
73 篇文章 0 订阅



Link:http://poj.org/problem?id=2955




Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4599 Accepted: 2442

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source



题意:给出一段由括号组成的字符串,求该字符串最大的匹配长度。


编程思想:区间DP。

设dp[i][j]表示区间i到j最大的括号匹配长度,则从后往前推,当匹配到第i个括号时,先假设第i个括号后面的括号没有能与它匹配的,那么状态转移为dp[i][j]=dp[i+1][j];然后从枚举区间i+1到j,若有与括号i匹配的,则求能匹配的最大值,若全部都没有与之匹配的,那么dp[i][j]=dp[i+1][j];所以当有与括号i匹配的括号k时,状态转移为dp[i][j]=max(dp[i][j],dp[i+1][k]+dp[k][j]+2);其中dp[i+1][k]+dp[k][j]+2中的2就是加上括号k与括号i匹配的长度。


AC code:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<cstring>
#include<cmath>
#include<vector>
using namespace std;
char str[111];
int dp[111][111];//dp[i][j]表示区间i到j最大的括号匹配数
int main()
{
    //freopen("D:\\in.txt","r",stdin);
    int i,j,k,len;
    while(scanf("%s",str+1)!=EOF)
    {
        if(strcmp(str+1,"end")==0)
            break;
        len=strlen(str+1);
        memset(dp,0,sizeof(dp));
        for(i=len-1;i>=1;i--)//枚举区间起点
        {
            for(j=i+1;j<=len;j++)//枚举区间终点
            {
                dp[i][j]=dp[i+1][j];
                if(str[i]=='('||str[i]=='[')
                {
                    for(k=i+1;k<=j;k++)
                    {
                        if(str[k]==')'&&str[i]=='(')
                            dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k][j]+2);
                        if(str[k]==']'&&str[i]=='[')
                            dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k][j]+2);
                    }
                }
            }
        }
        printf("%d\n",dp[1][len]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值