Two Rabbits

点击打开链接


Problem Description
Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time.  

Now they want to find out the maximum turns they can play if they follow the optimal strategy.
 

Input
The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.
 

Output
For each test case, print a integer denoting the maximum turns.
 

Sample Input
 
 
1 1 4 1 1 2 1 6 2 1 1 2 1 3 0
 

Sample Output
 
 
1 4 5
Hint
For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2. For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.

题解一

/*又出现了循环的题,还是把数字复制一份放在后面。但是就有问题了,我不知道怎样怎样区间dp这个不连续

后来知道 dp[i][j]=max(max(dp[i][j-1],dp[i+1][j]),dp[i][j]+=val[i]==val[j]?0:2);这就是求得不连续,当然连续也是可以

比如 1 3 4 2 1,dp[1][5]=3.一开始我都不信,你可以试试。

但是又出现一个问题我想的是ans=min(n,dp[1][2*n]), 但是样例3就是过不了,应该是5,

2 1 1 2 1 3 ,2 1 1 2 1 3,我把划窗设置成n,所以一直是4,答案为着色区域,

有两种解决方案

1.分段,因为发现主要是把起跳点给丢了。所以如果可以分成两端,a是回文,b是回文 ab形成的环也是回文。正好也就是答案了。

2.同样的思想还是将一个点单独拿出来,把他作为起跳点,直接加1,划窗变为n-1

*/

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int maxn = 1000 + 10;
int val[2*maxn];
int dp[2*maxn][2*maxn];

int main()
{
	int n;
	while(scanf("%d",&n)&&n) {
		for(int i=1; i<=n; i++)
			scanf("%d",&val[i]);
		for(int i=n+1; i<=2*n; i++)
			val[i]=val[i-n];
		int ans=0;
		memset(dp,0,sizeof(dp));
		for(int l=1; l<=n; l++) {
			for(int i=1; i<=n-l+1; i++) {
				int j=i+l-1;
				dp[i][j]=1;//最小值
				if(i!=j&&val[i]==val[j])
					dp[i][j]=dp[i+1][j-1]+2;
				else
					dp[i][j]=max(dp[i][j],max(dp[i+1][j],dp[i][j-1]));
			}
		}
		ans=1;
		for(int i=1; i<=n; i++) {
			ans=max(ans,dp[1][i]+dp[i+1][n]);
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值