Poor Warehouse Keeper HDU - 4803 (卡精度)

Jenny is a warehouse keeper. He writes down the entry records everyday. The record is shown on a screen, as follow:


There are only two buttons on the screen. Pressing the button in the first line once increases the number on the first line by 1. The cost per unit remains untouched. For the screen above, after the button in the first line is pressed, the screen will be:


The exact total price is 7.5, but on the screen, only the integral part 7 is shown.
Pressing the button in the second line once increases the number on the second line by 1. The number in the first line remains untouched. For the screen above, after the button in the second line is pressed, the screen will be:


Remember the exact total price is 8.5, but on the screen, only the integral part 8 is shown.
A new record will be like the following:


At that moment, the total price is exact 1.0.
Jenny expects a final screen in form of:


Where x and y are previously given.
What’s the minimal number of pressing of buttons Jenny needs to achieve his goal?

Input

There are several (about 50, 000) test cases, please process till EOF.
Each test case contains one line with two integers x(1 <= x <= 10) and y(1 <= y <= 10 9) separated by a single space - the expected number shown on the screen in the end.

Output

For each test case, print the minimal number of pressing of the buttons, or “-1”(without quotes) if there’s no way to achieve his goal.

Sample Input

1 1
3 8
9 31

Sample Output

0
5
11


        
  

Hint

For the second test case, one way to achieve is:
(1, 1) -> (1, 2) -> (2, 4) -> (2, 5) -> (3, 7.5) -> (3, 8.5)

        
 
#include<bits/stdc++.h>
using namespace std;

typedef long long ll;

#define rep(i,a,b) for(int i=a;i<b;++i)
#define per(i,a,b) for(int i=b-1;i>=a;--i)

const double eps=1e-6;

int main()
{
	//freopen("123.txt","r",stdin);
	//freopen("789.txt","w",stdout);
    ll a, b;
    while(~scanf("%lld%lld", &a, &b)){
        if(a>b){
            printf("-1\n");
            continue;
        }
        ll ans=999999999999999999;
        double k=1.*b/a;

        ll cos=0;
        double px=1, py=1;
        for(ll i=1; i<=a; i++){
            ll ty=ll(k*i);//mu biao dian

			cos+=ty-ll(py);//hua fei
            py=py+ty-ll(py);//yi dong

            if(py-k*i>0){
				py-=1;
				cos-=1;
			}

            //cout<<px<<" "<<py<<"cos: "<<cos<<endl;
            double np=py+1;
            ty=np + np/i*(a-i);//zhi jie dao
            if(ty==b) ans=min(ans, cos+1+a-i);

            if(i!=a){
               // py=py+py/px;
                py=py/px*(px+1);
                px+=1;
                cos++;
            }
        }
        cos+=(b-ll(py+eps));
        ///!!! 最后这里,很可能会 直接掉下去,所以对于需要结果的地方,我们得加上一个eps,尤其是取整的时候,
        ///而且这个eps,不能太小,要不然,就没有用了
        //printf("px:%f py:%f\n",px,py);
        ans=min(cos, ans);
        printf("%lld\n", ans);

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值