1145 Hashing - Average Search Time

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

这里问到了 HASH,忘了原理。

 

     其实就是不断的 +d*d, 因为前面可能冲突,所以需要散开。  那么这个d应该加到多少呢,我的第一想法就是 直到>=p,但这是不对的,因为后面的余数可能和前面的不同。

   所以我们假设  d=(p+x)  ,所以 d*d=(p+x)*(p+x)=p^2+2*p*x+x*x,  我们发现 只剩下了  x*x, 所以当 d=p+0,的时候,他就已经重复了,所以我们只要算到 d=p-1

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;

#define rep(i,a,b) for(int i=a;i<b;++i)
#define bug(x) printf("**%d\n",x)

const int N=2e5+10;

int is_pri(LL x){
	if(x<=1)return 0;

	int m=sqrt(x+0.5);
	for(int i=2;i<=m;i++){
		if(x%i==0)return 0;
	}
	return 1;
}

int P,n,m;
int has[N];

int insert(LL x){
	LL t=0,tmp=x;
	while(t<=P-1){
		x=(tmp+t*t)%P;
		if(has[x]==-1){
			has[x]=tmp;
			return 1;
		}
		t++;
	}
	return 0;
}

double cal(LL x){
	LL t=0;
	LL tmp=x;
	double sum=0;
	while(t<=P-1){
		sum+=1;
		x=(tmp+t*t)%P;
		//printf("x:%lld %d\n",x,has[x]);
		if(has[x]==-1||has[x]==tmp)return sum;
		t++;
	}
	return sum+1;//猜测可能是 又回到了循环的起点,所以还是要+1的,要不然
                      //循环的最后一个点,和不存在是相同的比较次数了,就不合理了
}


int main()
{
	scanf("%d %d %d",&P,&n,&m);

	if(!is_pri(P)){
		for(;;P++){
			if(is_pri(P)){
				break;
			}
		}
	}

	//printf("*****P:%d\n",P);

	rep(i,0,P+1)has[i]=-1;

	rep(i,0,n){
		LL x;
		scanf("%lld",&x);
		if(!insert(x)){
			printf("%d cannot be inserted.\n",x);
		}
	}

	double sum=0;

	rep(i,0,m){
		LL x;
		scanf("%lld",&x);
		sum+=cal(x);

		//printf("i:%d sum:%.0f\n",i,sum);
	}

	printf("%.1f\n",sum/m);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值