『1145』Hashing - Average Search Time

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be   where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than  . Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than  .

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

Ω

救命,哈希题好难啊。给出表大小 (如果不为素数需要找到 的最小素数 ), 个待插入的数, 个需要查询的数。对不能插入的数进行输出,最后输出平均搜索时间。

如果插入时存在冲突采取二次探测法,详见上一道hash题「1078」Hashing。对于无法插入的键值最多只需 次,关键是平均搜索时间的计算。

每一次键值的比较都算是一个单位的搜索时间,但问题是不存在键值的搜索时间是否是一个固定时间,答案是否定的。因为不存在的键值有两种情况:1. 未曾尝试插入过,2. 尝试插入过但失败了。对于case 2,你需要 次搜索(最后一次发现回到起点也算,虽然我觉的没什么必要);而对于case 1,在你采取二次探测法查找键值时如果发现某个位置为空,就说明它之前没有插入过,应该直接停止搜索。


🐎

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

bool isPrime(int n)
{
    if (n == 1) return false;
    if (n == 2) return true;
    for (int i = 2; i <= sqrt(n); i += (i == 2 ? 1 : 2))
        if (n % i == 0) return false;
    return true;
}

int main()
{
    int t, n, m, k, bias = -1, cnt = 0;
    cin >> t >> n >> m;
    while (!isPrime(t)) ++t;
    vector<int> hash(t, 0);
    for (int i = 0; i < n; ++i, bias = -1)
    {
        cin >> k;
        while (++bias < t && hash[(k + bias * bias) % t]);
        if (bias == t) printf("%d cannot be inserted.\n", k);
        else hash[(k + bias * bias) % t] = k;
    }
    for (int i = 0; i < m; ++i, bias = -1)
    {
        cin >> k;
        while (++cnt, ++bias < t && hash[(k + bias * bias) % t] != k && hash[(k + bias * bias) % t] != 0);
    }
    printf("%.1f", 1.0 * cnt / m);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值