1133 Splitting A Linked List (25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

 

   这道题 真的是 神迷,不知道到底哪里减了 一分, 看到别人的博客 说有可能这 n个不是一条链上的, 一口老血。

真的太坑了,我的变量都是n.

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)

const int N=1e5+10;

map<int,int> pos;

struct Node{
	int p1,p2,val;
}p[N],res[N];

int order[N];

/*
00000 0 0
00000 18 00001
00001 -1 -1

*/

int main(){
	//int n;
	//scanf("%d",&n);
	int st,n,K;
	scanf("%d %d %d",&st,&n,&K);
	rep(i,1,n+1){
		scanf("%d %d %d",&p[i].p1,&p[i].val,&p[i].p2);
		pos[p[i].p1]=i;
	}

	int tmp=st,cnt=0;
	while(n&&tmp!=-1){
		order[cnt++]=pos[tmp];
		tmp=p[pos[tmp]].p2;
	}

	//rep(i,0,cnt)printf("i:%d %d\n",i,order[i]);
	int tot=cnt;
	cnt=1;
	for(int i=0;i<tot;i++){
		if(p[order[i]].val<0){
			res[cnt++]=p[order[i]];
			res[cnt-2].p2=res[cnt-1].p1;
		}
	}

	for(int i=0;i<tot;i++){
		if(p[order[i]].val>=0&&p[order[i]].val<=K){
			res[cnt++]=p[order[i]];
			res[cnt-2].p2=res[cnt-1].p1;
		}
	}

	for(int i=0;i<tot;i++){
		if(p[order[i]].val>K){
			res[cnt++]=p[order[i]];
			res[cnt-2].p2=res[cnt-1].p1;
		}
	}

	//printf("*****\n");
	for(int i=1;i<cnt;i++){//这里的 cnt 不要写成 n
		if(i<cnt-1)
			printf("%05d %d %05d\n",res[i].p1,res[i].val,res[i].p2);
		else
			printf("%05d %d -1\n",res[i].p1,res[i].val);
	}

	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值