2128 Problem C How Many Tables

在Ignatius的生日派对上,他邀请了许多朋友。每个朋友不都互相认识,且都不想和陌生人坐在一起。题目要求根据朋友之间的认识关系,确定至少需要多少张桌子。规则是如果A认识B,B认识C,那么A、B、C可以坐在同一张桌子上。给定朋友数量N和他们之间的认识关系M对,需要计算最少需要多少张桌子。
摘要由CSDN通过智能技术生成

问题 C: How Many Tables

时间限制: 1 Sec  内存限制: 32 MB
提交: 119  解决: 93
[提交][状态][讨论版][命题人:外部导入]

题目描述

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入

2
6 4
1 2
2 3
3 4
1 4

8 10
1 2
2 3
5 6
7 5
4 6
3 6
6 7
2 5
2 4
4 3

样例输出

3
2
#include<iostream>
using namespace std;
int f[1050];
int seek(int x) {
	if (x == f[x]) return x;
	else {
		int FX = seek(f[x]);
		f[x] = FX;
		return FX;
	}
}
int main() {
	int n, m, t, a, b;
	cin >> t;
	while (t--) {
		cin >> n >> m;
		for (int i = 1; i <= n; i++) f[i] = i;
		while (m--) {
			cin >> a >> b;
			int FA = seek(a), FB = seek(b);
			if (FA != FB) f[FB] = FA;
		}
		int num = 0;
		for (int i = 1; i <= n; i++) {
			if (f[i] == i) num++;
		}
		cout << num << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值