杭电1213_How Many Tables——java(并查集)

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
 
 
2
5 3
1 2
2 3
4 5
5 1
2 5
 

Sample Output
 
 
2
4

题意:今天是Ignatius的生日。他邀请了很多朋友。现在是吃晚餐的时间。Ignatius想知道他至少需要多少张桌子。你必须注意到,不是所有的朋友都认识,所有的朋友都不想和陌生人呆在一起。
这个问题的一个重要的规则是,如果我告诉你A知道B,而B知道C,那意味着A B C知道彼此,这样他们就能呆在一张桌子里。
例如,如果我告诉你A知道B,B知道C,而D知道E,那么A B C可以留在一个表中,D E必须留在另一个表中。所以Ignatius至少需要两张桌子。


import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(new BufferedInputStream(System.in));
        int T = sc.nextInt();
        String temp = sc.nextLine();//读取换行符
        while ((T--) != 0) {
            while (sc.hasNextLine()) {
                String record = sc.nextLine();
                if("".equals(record))
                    continue;
                String[] ss = record.split(" ");
                int n = Integer.parseInt(ss[0]);
                int m = Integer.parseInt(ss[1]);
                int[] set = new int[n+1];
                for(int i = 1;i <= n;i++){//初始化set数组,每个人的顶头上司都是自己
                    set[i] = i;
                }
                int[][] data = new int[m+1][2];
                for(int i = 1;i <= m;i++){
                    data[i][0] = sc.nextInt();
                    data[i][1] = sc.nextInt();
                    relation(set,data[i][0],data[i][1]);
                }
                int count = 0;
                for(int i = 1;i<=n;i++){
                    if(set[i] == i)
                        count++;
                }
                System.out.println(count);
            }
        }
    }
    public static void relation(int[] set,int a,int b){
        int x = find(set,a);
        int y = find(set,b);
        set[x] = y;
    }
    public static int find(int[] set,int a){
        int res = a;
        //找出顶头上司
        while(set[res] != res){
            res = set[res];
        }
        while(a != res){
            int j = set[a];
            set[a] = res;
            a = j;
        }
        //返回顶头上司的结果
        return res;
    }

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值