数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory Limit: 65536KB
Submit Statistic
Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。
Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。
Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出”Yes”,否则输出”No”。
Example Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0
Example Output

Yes
No
No
Hint

Author

xam

AC code:

PS:直接将所给数据按照前序或者中后序排列,所得结果一致,即可行;

#include<bits/stdc++.h>

using namespace std;

struct node
{
    int data;
    struct node *lc, *rc;
};

void creat(struct node *&root, int st)//加上取地址符来确保root的值不会回溯
{
    if(root==NULL)
    {
        root= new node;
        root->lc=NULL;
        root->rc=NULL;
        root->data= st;
    }
    else
    {

        if(st < root->data)
            creat(root->lc,st);
        else
            creat(root->rc,st);
    }
}

int st2[100] = {0}, st3[100] = {0};
int i = 0;
/*void DLR(struct node * root)//前序遍历DLR
{
    if(root)
    {
        st2[i++] = root->data;
        DLR(root->lc);
        DLR(root->rc);
    }
}*/

void DLR1(struct node * root)
{
    if(root)
    {
        st3[i++] = root->data;
        DLR1(root->lc);
        DLR1(root->rc);
    }
}

/*int j = 0;
void houxu(struct node * root)
{
    if(root)
    {
        houxu(root->lc);
        houxu(root->rc);
        st3[j++] = root->data;
    }
}*/

int main()
{
    int n,l;
    while(cin>>n)
    {
        if(n == 0) break;
        cin>>l;
        int st[100] = {0}, st1[100] = {0};

        struct node* root = NULL;
        for(i = 0; i < n; i++)
        {
            cin>>st[i];
            creat(root, st[i]);
        }
        i = 0;
        qianxu(root);
        while(l--)
        {
            struct node*root1 = NULL;
            for(i = 0; i < n; i++)
            {
                cin>>st1[i];
                creat(root1, st1[i]);
            }
            i = 0;
            DLR1(root1);
            int flag = 1;
            for(i = 0; i < n; i++)
            {
                if(st2[i] != st3[i])
                    flag = 0;
            }

            if(flag == 1)
                cout<<"Yes"<<endl;
            else cout<<"No"<<endl;
        }
        memset(st2,0,sizeof(st2));
        memset(st3,0,sizeof(st3));
    }
    return 0;
}


/***************************************************
User name:
Result: Accepted
Take time: 0ms
Take Memory: 160KB
Submit time: 2017-02-13 20:58:23
****************************************************/
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值