别墅房间

别墅房间

时间限制(普通/Java) : 1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 120            测试通过 : 31 

描述

C大佬到他的朋友家别墅去玩,发现他朋友的家非常大,而且布局很奇怪。具体来说,朋友家的别墅可以被看做一个N*M的矩阵,有墙壁的地方被标记为’#’,其他地方被标记为’.’。两个格子(a,b)和(c,d)被当做在同一个房间内,当且仅当(c = a 且 |b - d| = 1)或(b = d 且 |a - c| = 1)。现在C大佬想知道,这个别墅有多少个房间?

输入

第一行输入一个整数T,表示数据组数。(1 <= T <= 20)

每组数据包含两个整数,N和M,分别表示别墅的长和宽(1 <= n, m <= 100)。

接下来N行描述别墅的情况,只包含’#’和’.’。

输出

每组数据输出一行,格式为:Case #x: y。其中x表示当前答案的属于第x组数据,y表示房间数。

样例输入

2
3 3
...
#..
.##
3 3
.#.
#.#
.#.

样例输出

Case #1: 2
Case #2: 5

代码如下:

#include <bits/stdc++.h>
//#include <ext/pb_ds/tree_policy.hpp>
//#include <ext/pb_ds/assoc_container.hpp>
//using namespace __gnu_pbds;
using namespace std;
 
 
#define pi acos(-1)
#define endl '\n'
#define me(x) memset(x,0,sizeof(x));
#define foreach(it,a) for(__typeof((a).begin()) it=(a).begin();it!=(a).end();it++)
#define close() ios::sync_with_stdio(0);
typedef long long LL;
const int INF=0x3f3f3f3f;
const LL LINF=0x3f3f3f3f3f3f3f3fLL;
const int dx[]={-1,0,1,0,-1,-1,1,1};
const int dy[]={0,1,0,-1,1,-1,1,-1};
const int maxn=1e3+5;
const int maxx=1e5+100;
const double EPS=1e-9;
const int MOD=1000000007;
#define mod(x) ((x)%MOD);
template<class T>inline T min(T a,T b,T c) { return min(min(a,b),c);}
template<class T>inline T max(T a,T b,T c) { return max(max(a,b),c);}
template<class T>inline T min(T a,T b,T c,T d) { return min(min(a,b),min(c,d));}
template<class T>inline T max(T a,T b,T c,T d) { return max(max(a,b),max(c,d));}
//typedef tree<pt,null_type,less< pt >,rb_tree_tag,tree_order_statistics_node_update> rbtree;
/*lch[root] = build(L1,p-1,L2+1,L2+cnt);
    rch[root] = build(p+1,R1,L2+cnt+1,R2);中前*/
/*lch[root] = build(L1,p-1,L2,L2+cnt-1);
    rch[root] = build(p+1,R1,L2+cnt,R2-1);中后*/
long long gcd(long long a , long long b){if(b==0) return a;a%=b;return gcd(b,a);}
 
inline int Scan()
{
    int res=0,ch,flag=0;
    if((ch=getchar())=='-')flag=1;
    else if(ch>='0' && ch<='9')res=ch-'0';
    while((ch=getchar())>='0'&&ch<='9')res=res*10+ch-'0';
    return flag ? -res : res;
}
const int N=110;
char mapp[N][N];
char visit[N][N];
int n,m;
void dfs(int x,int y)
{
    int xx,yy;
    for(int i=0;i<4;i++)
    {
        xx=x+dx[i];
        yy=y+dy[i];
        if(xx>=1&&yy>=1&&xx<=n&&yy<=m&&mapp[xx][yy]=='.'&&!visit[xx][yy])//确定不抄界,并且旁边都是自己人,并且未被标记过
        {
            visit[xx][yy]=1;
            dfs(xx,yy);
        }
    }
}
 
int main()
{
    int t;
    cin>>t;
    for(int k=1;k<=t;k++)
    {
        memset(mapp,0,sizeof(mapp));
        memset(visit,0,sizeof(visit));
        int sum=0;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        cin>>mapp[i]+1;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            if(mapp[i][j]=='.'&&!visit[i][j])
            {
                sum++;
                visit[i][j]=1;
                dfs(i,j);
            }
        }
        printf("Case #%d: %d\n",k,sum);
    }
     
}
 
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值