2015浙江省赛Beauty of Array

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

题意:给你一个串数字,求任意连续数字组成的串的各个数字的和(重复的只算一次)的和

题解:sum【i】与sum【i-1】有关系,找出,用一个数组记录每个数最后出现的下标来识别是否重复,具体看代码

代码:

#include<iostream>
#include <stdio.h>
using namespace std;
#define M 1000010
#include<algorithm>
#include <cstring>
long long pos[M];
long long sum[100010], s[100000];
long long a[100010];

int main()
{
	long long t;
	scanf("%lld", &t);
	while (t--)
	{
		memset(sum, 0, sizeof(sum));
		memset(s, 0, sizeof(s));
		memset(pos, 0, sizeof(pos));
		long long n;
		scanf("%lld", &n);
		for (long long i = 1; i <= n; i++) {
			scanf("%lld", &a[i]);
		}
		pos[a[1]] = 1, s[1] = a[1], sum[1] = a[1];
		for (long long i = 2; i <= n; i++) {
			s[i] = a[i] + s[i - 1] + (i - pos[a[i]] - 1)*a[i];
			sum[i] = sum[i - 1] + s[i];
			pos[a[i]] = i;
		}
		printf("%lld\n", sum[n]);
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值