HDOJ-1002 A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

不知道坑了多少人的题目~首先位数1000位long long也存不下,当然java很好做,然而目前没接触过,所以只能用数组存数来计算,然后一个地方要注意:它说每组测试数据 有空行隔开,也就是说最后一组数据后是没有空行的。这个没找出来,一直Presentation Error,看了Discuss后才知道自己错哪了。细节啊!!

//15MS  1676K
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int main(){
    int T,N=1;
    scanf("%d",&T);
    while(T--){
        char a[1005],b[1005];
        int ans[1005];
        scanf("%s %s",a,b);
        int len1,len2,len;
        len1=strlen(a);
        len2=strlen(b);
        len=max(len1,len2);
        for(int i=len-1,j=len2-1,k=len1-1;;i--,j--,k--){
            if(k>=0&&j>=0)
                ans[i]=a[k]-48+b[j]-48;
            else if(k>=0&&j<0)
                ans[i]=a[k]-48;
            else if(k<0&&j>=0)
                ans[i]=b[j]-48;
            else
                break;
        }
        for(int j=len-1;j>0;j--){
            if(ans[j]>9){
                ans[j-1]++;
                ans[j]-=10;
            }
        }
        printf("Case %d:\n%s + %s = ",N++,a,b);
        for(int k=0;k<len;k++)
            printf("%d",ans[k]);
        if(T==0)
            printf("\n");
        else
            printf("\n\n"); //囧~
    }
    return 0;
}

AC后觉得很Interesting~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值