HDOJ-1002-A + B Problem II


HDOJ-1002



A + B Problem II


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 506682 Accepted Submission(s): 97265

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

以字符形式读入,然后转换成int数组,这里注意两个数都要先空一位,因为可能最高位进位。把位数少的数前面补0,然后两个数组逐个位数相加,模拟十进制加法,超过10进位

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
char c[10005],d[10005];
int a[10005],b[10005],e[10006],maxx;
int t,h;
void solve()
{
    scanf("%s%s",c,d);
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(e,0,sizeof(e));
    maxx=max(strlen(c),strlen(d));
    if(strlen(c)>=strlen(d))
    { 
    for(int i=0;i<strlen(c);i++)
        a[i+1]=c[i]-'0';
    for(int i=1;i<1+strlen(c)-strlen(d);i++)
        b[i]=0;
    for(int i=1+strlen(c)-strlen(d);i<=strlen(c);i++)
        b[i]=d[i-(1+strlen(c)-strlen(d))]-'0';
    }
    else
    { 
    for(int i=0;i<strlen(d);i++)
        b[i+1]=d[i]-'0';
    for(int i=1;i<1+strlen(d)-strlen(c);i++)
        a[i]=0;
    for(int i=1+strlen(d)-strlen(c);i<=strlen(d);i++)
        a[i]=c[i-(1+strlen(d)-strlen(c))]-'0';
    }
    a[0]=b[0]=0;
    for(int i=maxx+1;i>=1;i--)
    {
        e[i]+=a[i]+b[i];
        if(e[i]>=10)
        {
            e[i]-=10;
            e[i-1]++;
        }
    }
    printf("Case %d:\n%s + %s = ",h-t,c,d);
    if(e[0]==0)
        for(int i=1;i<=maxx;i++)
            printf("%d",e[i]);
    else
        for(int i=0;i<=maxx;i++)
            printf("%d",e[i]);
    printf("\n");
    if(t!=0)
        printf("\n");
}
int main()
{
    /*
    freopen("da ta.in","r",stdin);
    freopen("data.out","w",stdout);
    */
    scanf("%d",&t);
    h=t;
    while(t--)
        solve();
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值