Nightmare

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius’ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius’ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1
Sample Output
4
-1
13

本题思路:简单的广搜即可。
但是需要注意的是,炸弹6秒会炸,并且走的路径可以重复,但其根本还是走的最短的步数,所以用广搜。
我们可以这样想,用一个map[][]来记录某点的数字,如果该点不是0,炸弹要炸的时间大于0秒,没有越界,则就可以判断该点是不是到达终点,是不是炸弹的时间可以重置(需要注意的是,炸弹重置只能重置一次,下次经过该点,不能再被重置)

#include<cstdio>
#include<iostream>
#include<queue>
using namespace std;
int dir[4][2]={0,1,1,0,-1,0,0,-1};
int map[10][10],m,n;
struct node
{
    int x,y;
    int time,step;
}start;

void bfs ()
{
    queue <node> q;
    struct node head,tail;
    q.push(start);
    int k;
    while(!q.empty())
    {
        head=q.front();
        q.pop();
        for(k=0;k<4;k++)
        {
            tail.x=head.x+dir[k][0];
            tail.y=head.y+dir[k][1];
            tail.time=head.time-1;
            tail.step=head.step+1;
            if(tail.x>=0&&tail.y>=0&&tail.x<n&&tail.y<m&&map[tail.x][tail.y]!=0&&tail.time>0)
            {
                if(map[tail.x][tail.y]==3)
                {
                    printf("%d\n",tail.step);
                    return;
                }
                else if(map[tail.x][tail.y]==4)
                {
                    tail.time=6;
                    map[tail.x][tail.y]=0;
                }
                q.push(tail);
            }
        }
    }
    printf("-1\n");
   return;
}
    int main()
{
    int i,j,T;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%d %d",&n,&m);
       for(i=0;i<n;i++)
         for(j=0;j<m;j++)
         {
            scanf("%d",&map[i][j]);
            if(map[i][j]==2)
            {
               start.x=i;
               start.y=j;
               start.step=0;
               start.time=6; 
            }
         }
         bfs(); 
    }
    return 0;
}

有什么想问的可以留言哦~~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值