题目描述
Description
求一棵二叉树的前序遍历,中序遍历和后序遍历
输入描述
Input Description
第一行一个整数n,表示这棵树的节点个数。
接下来n行每行2个整数L和R。第i行的两个整数Li和Ri代表编号为i的节点的左儿子编号和右儿子编号。
输出描述
Output Description
输出一共三行,分别为前序遍历,中序遍历和后序遍历。编号之间用空格隔开。
样例输入
Sample Input
5
2 3
4 5
0 0
0 0
0 0
样例输出
Sample Output
1 2 4 5 3
4 2 5 1 3
4 5 2 3 1
数据范围及提示
Data Size & Hint
n <= 16
#include<iostream>
using namespace std;
int l[20],r[20];
void afind(int x)
{
if(x<=0){return;}
cout<<x<<' ';
afind(l[x]);
afind(r[x]);
}
void bfind(int x)
{
if(x<=0){return;}
bfind(l[x]);
cout<<x<<' ';
bfind(r[x]);
}
void cfind(int x)
{
if(x<=0){return;}
cfind(l[x]);
cfind(r[x]);
cout<<x<<' ';
}
int main()
{
int n;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>l[i]>>r[i];
}
afind(1);
cout<<endl;
bfind(1);
cout<<endl;
cfind(1);
cout<<endl;
return 0;
}