思维题—待思考—card card card

As a fan of Doudizhu, WYJ likes collecting playing cards very much.
One day, MJF takes a stack of cards and talks to him: let’s play a game and if you win, you can get all these cards. MJF randomly assigns these cards into nn heaps, arranges in a row, and sets a value on each heap, which is called “penalty value”.
Before the game starts, WYJ can move the foremost heap to the end any times.
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the penaltyvaluepenaltyvalue.
If at one moment, the number of cards he holds which are face-up is less than the penaltyvaluepenaltyvalue, then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end.So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all “penalty value” is exactly equal to the number of all cards.
Input
There are about 1010 test cases ending up with EOF.
For each test case:
the first line is an integer nn (1≤n≤1061≤n≤106), denoting nn heaps of cards;
next line contains nn integers, the iithth integer aiai (0≤ai≤10000≤ai≤1000) denoting there are aiai cards in iithth heap;
then the third line also contains nn integers, the iithth integer bibi (1≤bi≤10001≤bi≤1000) denoting the “penalty value” of iithth heap is bibi.
Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.
Sample Input
5
4 6 2 8 4
1 5 7 9 2
Sample Output
4

Hint
[pre]
For the sample input:

  • If WYJ doesn’t move the cards pile, when the game starts the state of cards is:
    4 6 2 8 4
    1 5 7 9 2
    WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can’t pay the the “penalty value” of the third pile, the game ends. WYJ will get 12 cards.
  • If WYJ move the first four piles of cards to the end, when the game starts the state of cards is:
    4 4 6 2 8
    2 1 5 7 9
    WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards.

It can be improved that the answer is 4.

huge input, please use fastIO.
[/pre]

huge input, please use fastIO这句话表明:只能用scanf不能用cin>>;

网上这道题的解法怪多的,我只看懂了动态规划。
其实最早接触动态规划就是最大子序列和,稍微加一些条件我就不知怎么处理了。
是笨是笨还是笨。
但是学习别人的了,不理解我就一行一行代码去琢磨。
然后背下来。
再默写。
再琢磨。
先附上动态规划的解法:

#include<iostream>  
#include<cstring>  
#include<vector>  
using namespace std;  
typedef long long ll;  
struct node{  
    int a,b,c;  
};  
node p[2000005];  
int main()  
{  
    int n,k;  
    while(cin>>n){  
        for(int i=0;i<n;i++)  
            scanf("%d",&p[i].a);  
        for(int i=0;i<n;i++){  
            scanf("%d",&p[i].b);  
            p[i].c=p[i].a-p[i].b;  
            p[i+n]=p[i];  
        }  
        int maxx=p[0].c,ans1=0,ans=0,left1=0,right1=0,left=0,right=0;  
        for(int i=0;i<2*n;i++){  
            ans1+=p[i].c;  
            ans+=p[i].a;  
            right1=i;  
            if(ans>maxx){  
                    left=left1;  
                    right=right1;  
                    maxx=ans;  
                }
            if(ans1<0){  
                ans1=ans=0;  
                left1=i+1;  
            }  
            if(right1-left1>=n||left1>=n)  
                break;  
        }  
        cout<<left<<endl;  
    }  
    return 0;  
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值