AC自动机模板——HDU2222 Keywords Search

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 62125    Accepted Submission(s): 20552


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

Author
Wiskey
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2896  2243  2825  3341  3247 



思路:建立字典树升级为自动机  查找就行   这道题是AC自动机入门题  可以当作模板
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstring>
using namespace std;
struct ACa
{
    int next[500050][26];
    int fail[500050],end[500050];
    int root,cnt;//根结点,计数器
    int newnode()
    {
        for(int i=0;i<26;i++)
        {
            next[cnt][i]=-1;//子结点设为空
        }
        end[cnt++]=0;//以该结点结束的串数
        return cnt-1;
    }
    int clear(){//初始化
        cnt=0;//结点数重置
        root=newnode();//初始化根结点 //完成后root=0
    }
    int insert(char c[])
    {
        int now=root;
        int len=strlen(c);
        for(int i=0;i<len;i++)
        {
            if(next[now][c[i]-'a']==-1)//如果对应结点未建立,添加结点
                next[now][c[i]-'a']=newnode();
            now=next[now][c[i]-'a'];//否则沿结点继续
        }
        end[now]++;
    }
    void build()
    {
        queue<int>q;
        fail[root]=root;
        for(int i=0;i<26;i++){
            if(next[root][i]==-1)
                next[root][i]=root;
            else{//有结点则入队
                fail[next[root][i]]=root;
                q.push(next[root][i]);
            }
        }
        while(!q.empty())
        {
            int now=q.front();
            q.pop();
            for(int i=0;i<26;i++){
                if(next[now][i]==-1)
                  next[now][i]=next[fail[now]][i];//链接到fail指针对应结点的后面
                else{
                  fail[next[now][i]]=next[fail[now]][i];
                  q.push(next[now][i]);
                }
            }
        }
    }
    int query(char c[])
    {//查询
        int len=strlen(c);
        int now=root;
        int res=0;
        for(int i=0;i<len;i++)
            {
            now=next[now][c[i]-'a'];
            int temp=now;
            while(temp!=root)
            {
                res+=end[temp];
                end[temp]=0;
                temp=fail[temp];
            }
        }
        return res;
    }
};
char buf[1000500];
ACa ac;
int main(){
    int T,n;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        ac.clear();
        int i;
        for(i=1;i<=n;i++){
            scanf("%s",buf);
            ac.insert(buf);
        }
        ac.build();
        scanf("%s",buf);
        printf("%d\n",ac.query(buf));
    }
    return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值