北大Poj 1207

The 3n + 1 problem

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 61390 Accepted: 19469

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs. 
Consider the following algorithm: 

 

		1. 		 input n



		2. 		 print n



		3. 		 if n = 1 then STOP



		4. 		 		 if n is odd then   n <-- 3n+1



		5. 		 		 else   n <-- n/2



		6. 		 GOTO 2




Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 

 

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

Duke Internet Programming Contest 1990,uva 100


 

不难,但是很考验对题目的理解能力,要注意的地方很多!

 

最终代码如下: 

  • 最开始发现死循环算不出来,设了断点后发现for循环里判断条件与while冲突!(即while中的变量最终一定是1,如果你跟for循环里用的变量一样,那这个for循环肯定死循环了)
  • 重新设置了一个变量后,又发现count前后影响的问题,忘记在for循环的一开始将count置为1;(不然你的count一直在之前的累加)
  • 然后是最坑的一点,题目没有说给你的i和j一定是有序的! (虽然他给你的样例是这样)所以如果i是大于j的,要做一次交换;
  • 别以为这就结束了,输出的时候,题目是要求按给出的顺序输出的!所以还得保存之前的顺序。
#include <iostream>
using namespace std;
int main(void){
    int i(0),j(0),temp(0);

    while(cin>>i>>j){
        int k=j;
        int l=i;
        if(i>j){
            temp=i;
            i=j;
            j=temp;
        }
        int max=1;
        for(;i<=j;i++){
            int count =1;
            int m=i;
            while(m!=1){
                if(m%2==1) m=3*m+1;
                else m = m/2;
                count++;
            }
            if(max<=count) max=count;
        }
        cout<<l<<" "<<k<<" "<<max<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值