贪心——区间选点——ny_287 Radar

1973: Radar

时间限制: 1 Sec   内存限制: 64 MB
提交: 8   解决: 4
您该题的状态:未开始
[提交][状态][讨论版]

题目描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

输入

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. The input is terminated by a line containing pair of zeros

输出

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

样例输入

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

样例输出

Case 1: 2
Case 2: 1

提示

来源


题目智能推荐

1313 1294 2917 2143 1359 2637 

[ 提交][ 状态]

/*
题意:给定点集S={(xi,yi)i=1.2.3...n},求用圆心在x轴上,半径为r的圆覆盖S所需的圆的最少个数。
解题思路:先把给定的xi,yi,r转化为x轴上的区间,即圆心所在的区间,这样就转化为了区间选点问题。
先对右端点从小到大排序,右端点相同时,左端点从小到大排序。


每一个点以r为半径,在x轴上的投影的区间段。即是该区间段上任一点部署雷达,都可以覆盖岛屿。
 
*/ 
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct radar{
	double a,b;
}r[1005];
bool comp(radar a1,radar a2)
{
	if(a1.b!=a2.b)//对右端点从小到大排序
	return a1.b<a2.b;
	return a1.a<a2.a;//右端点相同,左端点从小到大排序 
}
int main()
{
int n,d,i,cas=0;
while(scanf("%d%d",&n,&d),n,d)
{
	double x,y;
	int flag=0,m=0;
	for(i=0;i<n;++i)
	{
		scanf("%lf%lf",&x,&y);//小岛坐标 
		if(fabs(y)>d)
		{
			flag=1;//高度大于半径,有覆盖不到的小岛 
			continue;
		}
		double diff=sqrt(d*d-y*y);
		r[i].a=x-diff;
		r[i].b=x+diff;
	}
	printf("Case %d: ",++cas);
	if(flag)
	{
		printf("-1\n");
		continue;
	}
	sort(r,r+m,comp);
	int cnt=1,p=0;
	
	for(i=1;i<m;++i)
	{
		if(r[p].b>=r[i].a)
		{
			continue;
			//区间重叠,不换 雷达 
		}
		else{
			cnt++;
			p=i; 
		} 
	}
	printf("%d\n",cnt);
}
return 0;
}         

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值