图论_最小生成树_prim算法_poj 1789_Truck History

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 31655 Accepted: 12342

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

对于有些题,需要抽象为图,在用对应的算法去解决

//题意大概是这样的:用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号衍生出来,代价是这两个编号之间相应的distance,现在要找出一个衍生方案,使得总代价最小,也就是distance之和最小。

例如有如下4个编号:

aaaaaaa

baaaaaa

abaaaaa

aabaaaa

显然的,第二,第三和第四编号分别从第一编号衍生出来的代价最小,因为第二,第三和第四编号分别与第一编号只有一个字母是不同的,相应的distance都是1,加起来是3。也就是最小代价为3

问题可以转化为最小代价生成树的问题。因为每两个结点之间都有路径,所以是完全图。 

此题的关键是将问题转化为最小生成树的问题。每一个编号为图的一个顶点顶点与顶点间的编号差即为这条边的权值,题目所要的就是我们求出最小生成树来。


//prim 算法
#include<iostream>
#include<cstring>
using namespace std;
const int inf=10;
const int maxn=2001;
int n;
char str[maxn][8];
int dist[maxn][maxn]={0};

int weight(int i,int j)
{//重新计算权值
	int w=0;
	for(int k=0;k<7;k++) 
		if(str[i][k]!=str[j][k])
			w++;
	return w;
}
int prim(void)
{
	int s=1;//源点 
	int m=1;//记录最小生成树的顶点数 
	bool vis[maxn];//记录某顶点是否属于最小生成树 
	int prim_w=0;//最小生成树总权值
	int min_w;//每个新源点到其他点的最短路 
	int pot;
	int cost[maxn];
	memset(cost,inf,sizeof(cost));
	memset(vis,false,sizeof(vis));
	vis[s]=true;
	while(1)
	{
		if(m==n)
			break;
		min_w=inf;
		for(int j=2;j<=n;j++)
		{
			if(!vis[j]&&cost[j]>dist[s][j])
				cost[j]=dist[s][j];//给cost赋初值 
			if(!vis[j]&&min_w>cost[j])
			{
				min_w=cost[j];//找到与源点相连最小的权值边 
				pot=j;
			}
		}
		s=pot;  //顶点j与旧源点合并 
		vis[s]=true; //j点并入最小生成树 
		prim_w+=min_w;//当前最小生成树的权值 
		m++;
	 } 
	 return prim_w; 
}
int main(void)
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	int i,j;
	while(cin>>n&&n)
	{
		for(i=1;i<=n;i++)
		 cin>>str[i];
		 
		for(i=1;i<=n-1;i++)
			for(j=i+1;j<=n;j++)
			dist[i][j]=dist[j][i]=weight(i,j);
		cout<<"The highest possible quality is 1/"<<prim()<<'.'<<endl; 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值