POJ 1789 Truck History 最小生成树 kruskal && Prim

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21548 Accepted: 8386

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

注-此题为: POJ 1789 Truck History

题意:
       用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。
       一个编号只能由另一个编号“衍生”出来,代价是这两个编号之间相应的distance,
       现在要找出一个“衍生”方案,使得总代价最小,也就是distance之和最小。
例如: 
有如下4个编号:
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
第二,第三和第四编号分别从第一编号衍生出来的代价最小,
因为第二,第三和第四编号分别与第一编号只有一个字母是不同的,相应的distance都是1,加起来是3。也就是最小代价为3。

转化为最小生成树:
每一个编号为图的一个顶点,顶点与顶点间的编号差即为这条边的权值,
       题目所要的就是我们求出最小生成树来。
用  克鲁斯卡尔 算法来求最小生成树。

已AC代码:(kruskal

#include<cstdio>
#include<cstring>
#define MAX 2002000
#include<algorithm>
using namespace std;

int n;
int per[2010];    // 并查集 
char ch[2010][10];

struct node{
	int u,v,w;   //w为不同个数 
}s[MAX];

bool cmp(node a,node b)
{
	return a.w<b.w;
}

void into()    //初始化 
{
	for(int i=0;i<=n;++i)
		per[i]=i;
}

int find(int x)  // 查找根节点 
{
	return x==per[x]?x:per[x]=find(per[x]);
}

bool join(int a,int b)  //合并根节点,并判断是否成环 
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	{
		per[fa]=fb;
		return true;
	}
	return false;
}

int main()
{
	int i,j,k,t,num;
	while(scanf("%d",&n),n)
	{
		memset(ch,'\0',sizeof(ch));
		for(i=0;i<n;++i)
			scanf("%s",ch[i]);
		k=0;
		for(i=0;i<n-1;++i)  //两两比较 
		{
			for(j=i+1;j<n;++j)
			{
				num=0;
				for(t=0;t<7;++t)  //记录两个字符串的不同个数 
					if(ch[i][t]!=ch[j][t])
						num++;
						
					s[k].u=i;
					s[k].v=j;
					s[k].w=num;
					k++;
			}
		}
		sort(s,s+k,cmp);    //按距离从小到大排序 
		into();    //初始化根节点 
		int sum=0;
		for(i=0;i<k;++i)
		{
			if(join(s[i].u,s[i].v))
			{
				sum+=s[i].w;
			}
		}
		printf("The highest possible quality is 1/%d.\n",sum);	
	}
	return 0;
}


已AC代码:(Prim

#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0xfffffff

int map[2010][2010],low[2010];
int vis[2010];   //map二维数组存图,low记录每2个点间最小权值,vis标记某点是否已访问
int n,sum;
char ch[2010][10];

void prim()
{
	int min;
	int i,j,pos=0;
	memset(vis,0,sizeof(vis));
	
	for(i=1;i<=n;++i)  	//从某点开始,分别标记vis和记录该点pos
		low[i]=map[1][i];  //第一次给low数组赋值 map的第一行 
	vis[1]=1;
	
	for(i=1;i<n;++i)   //再运行n-1次,一次找一个最小 
	{
		min=INF;
		for(j=1;j<=n;++j)
		{
			if(vis[j]==0&&low[j]<min)
			{
				min=low[j];
				pos=j;
			}
		}
		
		vis[pos]=1;   //标记该点已访问 
		sum+=min;   //最小权值累加
		
		for(j=1;j<=n;++j)     //更新权值low 把 map的 pos 行中比对应的 low 小的赋给low 
			if(vis[j]==0&&low[j]>map[pos][j])
				low[j]=map[pos][j];
	}
	return ;
}

int main()
{
	int i,j,t,num;
	while(scanf("%d",&n),n)
	{
		memset(ch,'\0',sizeof(ch));
		for(i=1;i<=n;++i)
			scanf("%s",ch[i]);

		for(i=1;i<n;++i)  //两两比较 
		{
			for(j=i+1;j<=n;++j)
			{
				num=0;
				for(t=0;t<7;++t)  //记录两个字符串的不同个数 
					if(ch[i][t]!=ch[j][t])
						num++;
						
				map[i][j]=map[j][i]=num;     //建图 
			}
		}

		sum=0;
		prim();
		printf("The highest possible quality is 1/%d.\n",sum);	
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值