hdu-1007-Quoit Design

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61249    Accepted Submission(s): 16222


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
 
 
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
 
 
0.71 0.00 0.75
 

Author
CHEN, Yue
 

Source

ZJCPC2004

平面最近点对模板题;

#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;
#define N 100005
struct point {
	double x,y;
}p[N];
int a[N];//保存筛选的点坐标 

int cmpx(point a,point b){
	return a.x<b.x;
}
int cmpy(int a,int b){//这里用的是下标索引 
	return p[a].y<p[b].y; 
}

double dis(point &a,point &b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double closest(int low,int high)
{
	if(low+1==high)
		return dis(p[low],p[high]);
	if(low+2==high)
		return min(dis(p[low],p[high]),min(dis(p[low],p[low+1]),dis(p[low+1],p[high])));
	int mid=(low+high)>>1;
	double ans=min(closest(low,mid),closest(mid+1,high));//分治法进行递归求解 
	int i,j,cnt=0;
	for(i=low;i<=high;++i)//把 x坐标在p[mid].x-ans~p[mid].x+ans范围内的点取出来 
	{
		if(p[i].x>=p[mid].x-ans&&p[i].x<=p[mid].x+ans)
		a[cnt++]=i; //保存的是下标索引 
	}
	sort(a,a+cnt,cmpy);//按y坐标进行升序排序
	for(i=0;i<cnt;++i)
	{
		int k=(i+7)>cnt?cnt:(i+7);//只要选取出 7个点
		for(j=i+1;j<k;++j)
		{
			if(p[a[j]].y-p[a[i]].y>=ans)//注意下标索引
				break;
			ans=min(ans,dis(p[a[i]],p[a[j]])); 
		 } 
	 } 
	 return ans;
}
int main()
{
	int n,i;
	while(~scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
		scanf("%lf%lf",&p[i].x,&p[i].y);
		sort(p,p+n,cmpx);
		printf("%.2lf\n",closest(0,n-1)/2);
	}
}
一维最近点对


#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;
#define maxn 1005
const int inf=0x3f3f3f3f;
double s[maxn]; 
double mn;
double closest(int low,int high)
{
	if(low+1==high) return s[high]-s[low];
	if(low+2==high) return min(s[low+1]-s[low],s[high]-s[low+1]);
	int mid=(low+high)>>1;
	double ans=min(closest(low,mid),closest(mid+1,high));
	if(ans>s[mid+1]-s[mid]) ans=s[mid+1]-s[mid];
	return ans;
}
//double Random() 
//{
//	double result=rand()%10000;//生成随机点对
//	return result*0.01; 
//}
int main()
{
	int n,m;
	srand(1);//生成随机点 
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		{
			s[i]=rand()%10000;
			printf("%lf ",s[i]);
		}
		printf("\n");
		sort(s,s+n);
		for(int i=0;i<n;i++)
		printf("%lf ",s[i]);
		printf("\n");
		printf("%.4lf\n",closest(0,n-1));
	 } 
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看rEADME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值