hdu 1715 大菲波数

大菲波数

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22722    Accepted Submission(s): 8163

Problem Description

Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3
计算第nFibonacci数值。

 Input

输入第一行为一个整数N,接下来N行为整数Pi1<=Pi<=1000)。

 Output

输出为N行,每行为对应的f(Pi)

Sample Input

5

1

2

3

4

5

 Sample Output

1

1

2

3

5

Source

2007省赛集训队练习赛(2

 

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
#define N 1010
string a[N];
string add(string s1,string s2)//模板
{
	int len1=s1.size();
	int len2=s2.size();
    if(len1<len2)
    {
    	swap(s1,s2);
    	swap(len1,len2);
	}
	int c=0;
	for(int i=len1-1,j=len2-1;i>=0;i--,j--)
	{
		c+=s1[i]-'0';
		if(j>=0)
		c+=s2[j]-'0';
		s1[i]=c%10+'0';
		c/=10;
	}
	if(c)
	 s1='1'+s1;
	return s1;
}

int main()
{
	ios::sync_with_stdio(false);//加快cin,cout的速度  
    cin.tie(0);  
	int n;
	a[1]='1';
	a[2]='1';
	for(int i=3;i<1005;i++)
	a[i]=add(a[i-1],a[i-2]);
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n;
		cout<<a[n]<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值