数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。
Output
输出二叉树的层次遍历序列。
Example Input
2
abd,,eg,,,cf,,,
xnl,,i,,u,,
Example Output
abcdefg
xnuli
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define maxsize 50
typedef struct node
{
    char data;
    struct node *lc,*rc;
}bitree;
bitree *queue[51];
int front=0,rear=0;
int i=-1;
bitree * pre_create(char str[51])
{
    bitree * t;
    if(str[++i]!=',')
    {
        t=(bitree *)malloc(sizeof(bitree));
        t->data=str[i];
        t->lc=pre_create(str);
        t->rc=pre_create(str);
    }
    else
    {
        t=NULL;
    }
    return t;
}
void enter_queue(bitree * t)
{
    if((rear+1)%maxsize!=front)
    {
        rear=(rear+1)%maxsize;
        queue[rear]=t;
    }
}
bitree * delete_queue(bitree * t)
{
    if(rear!=front)
    {
        front=(front+1)%maxsize;
        return queue[front];
    }
}
void level_order(bitree * t)
{
    bitree * p;
    if(t)
    {
        enter_queue(t);
    }
    while(front!=rear)
    {
        p=delete_queue(t);
        printf("%c",p->data);
        if(p->lc)
        {
            enter_queue(p->lc);
        }
        if(p->rc)
        {
            enter_queue(p->rc);
        }
    }
}
int main()
{
    int t;
    char str[51];
    bitree *tree;
    scanf("%d",&t);
    while(t--)
    {
        i=-1;
        scanf("%s",str);
        tree=pre_create(str);
        level_order(tree);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值