PAT 1124 Raffle for Weibo Followers python解法

1124 Raffle for Weibo Followers (20 分)
John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going…

题意:模拟微博抽奖,第一行给出3个数(m,n,s),分别表示参与抽奖人数,获奖人数,抽奖规则(隔s个人抽一个),如果原来被抽取过,则顺延到下一个。

解题思路:用列表candidate来保存获奖者昵称,首先判断参与抽奖人数n是否小于抽奖规则s,若小于则没有获奖者,输出Keep going…,否则先将s-=1(因为列表索引从0开始),开始循环判断昵称是否在candidate中,如果在,则s+=1,不在,则判断是否满足抽奖规则(i==s),满足则将昵称添加到candidate中,并将s+=n。

m, n, s = map(int,input().split())
#m, n, s = 9,3,2
#m, n, s = 2,3,5
l = []
for i in range(m):
    l.append(input())
#l = ['Imgonnawin!','PickMe']  
#l = ['Imgonnawin!','PickMe','PickMeMeMeee','LookHere','Imgonnawin!','TryAgainAgain','TryAgainAgain','Imgonnawin!','TryAgainAgain']
candidate = []
if s>n:
    print('Keep going...')
else:
	s -= 1
    for i in range(m):
        if l[i] in candidate:
            s += 1 
        if i == s and l[i] not in candidate:
            candidate.append(l[i])
            s += n       
    print('\n'.join(candidate))
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值