PAT 1149 Dangerous Goods Packaging python解法

1149 Dangerous Goods Packaging (25 分)
When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10​4 ), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
Sample Output:
No
Yes
Yes

题意:有一些物品不能混合到一起,如氧化剂和易燃液体,给出一份不能混合的物品清单以及一份发货清单,需要判断发货清单中是否有不能混合的物品,有则输出No,否则输出Yes。

解题思路:将不能混合的物品清单中的每一项(也就是两个物品ID)存为一个集合incompatible,将发货清单也存为一个集合set1,对incompatible做循环,如果其中有元素是set1的子集(也可以判断set1是不是incompatible元素的父集,但效率没有判断子集高,会导致一个测试点超时),则输出No,并跳出循环,如果循环结束还没输出No,则输出Yes。

n, m = map(int,input().split())
incompatible = []
for i in range(n):
    incompatible.append(set(input().split()))
for i in range(m):
    goods = list(input().split())
    set1 = set(goods[1:])
    j = 0
    while j < n:
#       if set1.issuperset(incompatible[j])): 
        if incompatible[j].issubset(set1):
            print('No')
            break
        j +=1
    if j == n:
        print('Yes')
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值