PAT 1112 Stucked Keyboard python解法

1112 Stucked Keyboard (20 分)
On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest

题意:键盘上有的键被卡住了,按1次会打印出k次。给出一个数字k和一个字符串,按顺序输出被卡住的键和正常的打印结果。

解题思路:
1.先将字符串s中出现k次的字符删掉,还留下的字符就是正常的。
2.用out存储最初的s,用stuck存储卡住的键,对out中的每个字符i,如果i不在s中并且不在stuck中,则将该字符添加到stuck中。
3.对stuck中的每个字符i,将out中k个i替换为1个i。

n = int(input())
s = input()
#n = 3
#s = 'caseee1__thiiis_iiisss_a_teeeeeest'
out = s
stuck = ''
for i in s:
    s = s.replace(i*n,'')
for i in out:
    if i not in s and i not in stuck:
        stuck += i
print(stuck)
for i in stuck:
    out = out.replace(i*n, i)
print(out)
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值