HDU 1004

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114462    Accepted Submission(s): 44814


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
 

Author
WU, Jiazhi
 

Source
 

Recommend
JGShining

记得开始做这道题时,想了好久。其实这道题是一道模拟题,主要是敲代码不会,思路上没什么好说的(不过还是要说一下)
思路上:
       利用冒泡排序的方法将所有的颜色比较一遍,记录每种颜色的个数。
代码上:
#include<iostream>
using namespace std;
#include<string>     //交题的话,这个头文件必须要有
int main()
{    
    
    int N;
    while((cin>>N))  //输入N,代表下面有N个数据。
    {
        string q[1001];    
        int i,j,b[1001]={0};
        if(N==0)    //除非N等于0,否则程序一直执行
        break;
    for(i=0;i<N;i++)
    cin>>q[i];
    int max=0,t=0;
    for(i=0;i<N;i++)   //冒泡排序,比较每种颜色
    {
        for(j=0;j<N;j++)
        {
            if(q[i]==q[j])
                b[i]++;    //当前颜色的个数。当程序执行完成时,所有red颜色的个数均相同(以第一个例子为例)
        }
    }
    for(i=0;i<N;i++)
    {
        if(b[i]>max)
        {
            max=b[i];   //找出个数最多的颜色
             t=i;     //将下标赋值给t
        }
    }
    cout<<q[t]<<endl;  //这里的t即i,变化的是b[i],i始终没变。
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值