HDU 1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164324    Accepted Submission(s): 40443


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
ZJCPC2004

开始没接触递归时,做过这道题,毫无意外的超时了。过后大神一说思路就明白了。代码没什么难度,只是思路有点绕。
思路:
            题目上给的公式看似简单,但关键地方就在这里。f(n)的结果是   A*f(n-1)+B*f(n-2)除以7的余数。一开始做的时候没想这么深。只是想到f(n)的结果只有7种。
后来发现 这里一共有f(n-1)和·f(n-2)两个变量。也就是说,要想f(n)的结果与某一个f(k)的结果相同。需要f(n-1)和f(n-2)两个变量均与另外f(k)的两个相同。
故共有7*7=49种结果。
代码:
#include<iostream>
using namespace std;
int main()
{
    int A,B,n,i,num[49]={0};
    while(cin>>A>>B>>n)
    {
        if((A+B+n)==0)
        break;
        num[0]=1,num[1]=1;
        for(i=2;i<49;i++)
        {
            num[i]=(A*num[i-1]+B*num[i-2])%7;
        }
        cout<<num[(n-1)%49]<<endl;  //这里需要注意的是数组的下标是从0开始的。
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值