L2-011. 玩转二叉树

L2-011. 玩转二叉树

https://www.patest.cn/contests/gplt/L2-011

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2

#include <iostream>
#include <algorithm>
#include <cstring>
#include <functional>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;

typedef long long ll;
const int MAXN = 35;
int preOrder[MAXN];
int inOrder[MAXN];
vector<vector<int> >order(MAXN);//order[i]保存了层序遍历中第i层的结果
void rebuild(int preL, int inL, int n, int c)
{
	if (n == 0)
		return;
	order[c].push_back(preOrder[preL]);
	if (n == 1)
		return;
	int i;
	for (i = 0; i < n; ++i)
		if (preOrder[preL] == inOrder[inL + i])
			break;
	rebuild(preL + i + 1, inL + i + 1, n - i - 1, c + 1);
	rebuild(preL + 1, inL, i, c + 1);
}

int main()
{
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
	ios::sync_with_stdio(false);
	cin.tie(0);
	int n;
	while (cin >> n)
	{
		for (int i = 0; i < n; ++i)
			cin >> inOrder[i];
		for (int i = 0; i < n; ++i)
			cin >> preOrder[i];
		order.clear();
		order.resize(35);
		rebuild(0, 0, n, 1);
		bool flag = false;
		for (int i = 0; i <= 30; ++i)
		{
			if (order[i].size() == 0)
				continue;
			for (int j = 0; j < order[i].size(); ++j)
			{
				if (flag == false)
					flag = true;
				else
					cout << " ";
				cout << order[i][j];
			}
		}
		cout << endl;
	}


	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值