2019年12月PAT甲级 第二题 Block Reversing(1165)题解

题目

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (   ≤ \ \leq  ​​   1 0 5 \ 10^5  105 ) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:
71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

解释

  本题是常规的链表题,注意地址输出的时候使用%05d。
  我使用vector存储有效的结点,将翻转后的结点依次存入ans。是否整除k影响第一个输入的结点的下标。除此之外就是常规的了。

正确代码

#include<iostream>
#include<climits>
#include<cctype>
#include<map>
#include<unordered_map>
#include<set>
#include<vector>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
struct node{
    int add, val, next;
}list[100000];
int main(){
    int n, temp, start ,k;
    cin >> start>> n >> k;
    vector<node> v, ans;
    for(int i = 0; i < n; i++){
        scanf("%d", &temp);
        list[temp].add = temp;
        scanf("%d %d", &list[temp].val, &list[temp].next);
    }
    for(int i = start; i != -1; i = list[i].next){
        v.push_back(list[i]);
    }
    int m = v.size();
    int i = m % k == 0 ? (m / k - 1) *k  : m / k * k;
    for(; i >= 0; i -= k){
        for(int j = i; j < i + k && j < m; j++)
            ans.push_back(v[j]);
    }
    for(int l = 0; l < ans.size(); l++){
        printf("%05d %d", ans[l].add, ans[l].val);
        if(l != ans.size() - 1) printf(" %05d\n",ans[l + 1].add);
        else printf(" -1");
    }
    return 0;
}
  • 4
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值