2018-7-28第二次训练赛-A

A - Let the Balloon Rise

HDU - 1004

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

大致意思:

每组数据第一行一个n(n为0则结束),随后n个字符串,找出出现次数最多的字符串。

很直白的题目,用map会很方便,但是我map还不习惯用,使用的循环查找方法。


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>

using namespace std;

bool _equal(char*a, char*b) {
    while (*a && *a==*b){a++;b++;}
    return *a==*b;
}

void _set(char*a, char*b) {
    while (*b) {
        *a=*b;
        a++;b++;
    }
    *a = 0;
}

int main()
{
    int n;
    char a[17];
    char b[1005][17];
    int c[1005];
    bool flag;
    int bcount,i,maxx;
    while (~scanf("%d", &n) && n) {
        bcount = 0;
        fill(c,c+1005,1);
        while (n--) {
            flag = false;
            scanf("%s", a);
            for (i=0; i<bcount; i++) {
                if (_equal(a, b[i])) {
                    c[i]++;
                    flag = true;
                    break;
                }
            }

            if (!flag) {
                _set(b[bcount++], a);
            }
        }

        maxx = 0;
        for (i=1; i<bcount; i++) {
            if (c[i] > c[maxx]) {
                maxx = i;
            }
        }
        printf("%s\n", b[maxx]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值