蓝桥杯练习【STL训练】——Let the Balloon Rise

题目描述:

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.This year, they decide to leave this lovely job to you.

输入:

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.A test case with N = 0 terminates the input and this test case is not   to be processed.

输出:

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

样例输入:

5 
green 
red 
blue 
red 
red 
3 
pink 
orange 
pink 
0

样例输出:

red 
pink

解题思路:

用map数组来存储,第一个元素保存气球的颜色,第二个元素保存该颜色气球的个数。最后通过循环比较找出数量最多的那个颜色的气球

参考代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    string s;
    while(cin>>n,n){ //输入一个数,且此数不为零时进入循环
        map<string,int> p; //第一个元素保存气球颜色,第二个元素保存这一颜色的气球的个数
        for(int i=0;i<n;i++){
            cin>>s;
            if(p.count(s))//若m已有该颜色气球个数的记录,则直接将数量+1
            p[s]++;
            else //若没有该颜色气球的记录,则插入相关颜色和个数的记录
            p.insert(make_pair(s,1)); //map是存储park的容器,可以通过insert一个pair来添加,可以直接调用make_pair生成pair对象
        }
        int max=0;
        string mark;
        for(map<string,int>::iterator it=p.begin();it!=p.end();it++){
            if(max<it->second){
                max=it->second;
                mark=it->first;
            }
        }
        cout<<mark<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值