F - Uniform Generator
HDU - 1014
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form
seed(x+1) = [seed(x) + STEP] % MOD
where '%' is the modulus operator.
Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.
For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.
If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.
Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.
Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
Sample Input
3 5 15 20 63923 99999
Sample Output
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
大致意思:
一个数字从1开始,每次加STEP并对MOD取模,判断最终MOD以下的所有数字是否都出现。
神一样的超级长题干,但是题目思路比较简单,核心思想是互质。
具体推理:
根据数学规律,S(STEP)可以直接对M(MOD)取模 S%=M
从数轴上选取多个连续的M长度,可以观察到,每次S超出M的范围产生的结果与每次将S点集向左平移M长度得到的结果相同
于是同样由数学规律可知,可以直接使M%=S
然后便进入了互相取模的循环(这便是中国古代求最大公约数的方法)
最后若得到1,则相当于每次将S点集左移一单位,必然可以布满数轴。(同时这也是互质的条件)
否则不行
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
bool math(int a,int b) {
a %= b;
while (a&&a!=1) {
b %= a;
swap(a,b);
}
return a==1;
}
int main()
{
int a,b;
while (~scanf("%d%d", &a, &b)) {
printf("%10d%10d ", a, b);
printf(math(a,b) ? "Good Choice\n\n" : "Bad Choice\n\n");
}
return 0;
}