More is better (九度 OJ 1444)

More is better (九度 OJ 1444)

时间限制:1 秒 内存限制:32 兆 特殊判题:否

1.题目描述:

Mr Wang wants some boys to help him with a project. Because the project is
rather complex, the more boys come, the better it will be. Of course there are certain
requirements. Mr Wang selected a room big enough to hold the boys. The boy who are
not been chosen has to leave the room immediately. There are 10000000 boys in the
room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection
any two of them who are still in this room should be friends (direct or indirect), or
there is only one boy left. Given all the direct friend-pairs, you should decide the best
way.
输入:
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of
direct friend-pairs. The following n lines each contains a pair of numbers A and B
separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B
≤ 10000000)
输出:
The output in one line contains exactly one integer equals to the maximum
number of boys Mr Wang may keep.
样例输入:
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
样例输出:
4
2

2.基本思路

在畅通工程的基础上,再引入一个集合用于标记每个根结点下集合元素的个数。

3.代码实现

#include <iostream>
#define N 10000001
using namespace std;
int Tree[N];
int Sum[N];//sum[i]表示以i为根结点的树中有sum[i]个结点

int findRoot(int x){
    if(Tree[x]==-1)return x;
    else {
        int tmp = findRoot(Tree[x]);
        Tree[x] = tmp;
        return tmp;
    }
}

int main()
{
    int n;
    int a,b;
    while(scanf("%d",&n)!=EOF){
        if(n==0)break;
        for(int i=1;i<=N;i++){//必须遍历到N,因为n组数据还有编号大于N的元素
            Tree[i]=-1;
            Sum[i]=1;
        }
        for(int i=1;i<=n;i++){
            scanf("%d%d",&a,&b);
                int rootA = findRoot(a);
                int rootB = findRoot(b);
                if(rootA!=rootB){//若不在一个集合内
                    Tree[rootA] = rootB;//把集合A放入B中
                    Sum[rootB]+=Sum[rootA];//累加根结点的集合元素个数
                }
        }
        int max=0;
        for(int i=1;i<=N;i++){
            if(Tree[i]==-1&&Sum[i]>max)
                max=Sum[i];
        }
        printf("%d\n",max);
    }
    return 0;
}
/*
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
*/
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值