【PAT甲级A1018】Public Bike Management (30分)(c++)

1018 Public Bike Management (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3​​ , we have 2 different shortest paths:

PBMC -> S​1​​ -> S​3​​ . In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​ , so that both stations will be in perfect conditions.

PBMC -> S​2​​ -> S​3​​ . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​ , the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​ , S​j​​ , and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​ . All the numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​ −>⋯−>S​p​​ . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

题意:

给出最大自行车容量cmax,要求在结点处的自行车数为cmax/2,从起点开始,找到离终点最近的路线,在路线确定的情况下,按顺序计算,每到一个点如果该点自行车数不足cmax/2,则计算需要从起点要缺少的数量,然后立马补上,再跑到下一个点。如果该点自行车过剩,则跑到下一个点进行判断。
例如:
经过的结点分别为6->2->9->10,cmax=10;

  • 那么经过6,我手里有一辆,去下一个点;
  • 经过2,补上我手里的一辆,还缺2辆,打个电话告诉总部,发两辆过来;
  • 再去9,现在手里有4辆,去下一个点;
  • 最后到10,所以我手里有9辆车收下来要带回总部。
  • 所以,总部需要send 2辆车以及back 9辆车

这题不能用连通器的想法去计算,就是说不能用后面多的去补前面少的,经过少的点就直接要补上,因为也不知道后面会不会多出来。

思路:

利用dijkstra最短路径算法加dfs深度遍历算法,需用记录每一条路径,对每一条最短路径的sendback(总部要发的车和回收到总部的车)进行判断,并不能放在dijkstra中单独判断。
参考代码:

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=510,INF=1e9;
int G[maxn][maxn],d[maxn];
int cmax,sp,c[maxn],n,m;
int minsend=INF,minback=INF;
bool flag[maxn]={false};
vector<int> pre[maxn],path,temppath;
void dij(int s){
    fill(d,d+maxn,INF);
    d[s]=0;
    for(int i=0;i<=n;i++){
        int u=-1,MIN=INF;
        for(int j=0;j<=n;j++){
            if(!flag[j]&&d[j]<MIN){
                u=j;
                MIN=d[j];
            }
        }
        if(u==-1)return;
        flag[u]=true;
        for(int v=0;v<=n;v++){
            if(!flag[v]&&G[u][v]!=INF){
                if(d[u]+G[u][v]<d[v]){
                    d[v]=d[u]+G[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }else if(d[u]+G[u][v]==d[v])
                    pre[v].push_back(u);
            }
        }
    }
}
void dfs(int v){
    if(v==0){
        int send(0),back(0);
        for(int i=temppath.size()-1;i>=0;i--){
            if(c[temppath[i]]>=cmax/2)back+=c[temppath[i]]-cmax/2;
            else if(back>=abs(c[temppath[i]]-cmax/2))
                back-=abs(c[temppath[i]]-cmax/2);
            else{
                send+=abs(c[temppath[i]]-cmax/2)-back;
                back=0;
            }
        }
        if(send<minsend){
            minsend=send;
            minback=back;
            path=temppath;
        }else if(send==minsend&&back<minback){
            minback=back;
            path=temppath;
        }
        return;
    }
    temppath.push_back(v);
    for(int i=0;i<pre[v].size();i++)
        dfs(pre[v][i]);
    temppath.pop_back();
}
int main() {
    fill(G[0],G[0]+maxn*maxn,INF);
    scanf("%d%d%d%d",&cmax,&n,&sp,&m);
    for(int i=1;i<=n;i++)scanf("%d",&c[i]);
    int si,sj,tij;
    for(int i=0;i<m;i++){
        scanf("%d%d%d",&si,&sj,&tij);
        G[si][sj]=G[sj][si]=tij;
    }
    dij(0);
    dfs(sp);
    printf("%d 0",minsend);
    for(int i=path.size()-1;i>=0;i--)
        printf("->%d",path[i]);
    printf(" %d\n",minback);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值