【PAT甲级A1035】Password (20分)(c++)

1035 Password (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题意:

将个人的密码信息中的“1l0O”改成“@L%o”,并输出修改后的信息。若没有需要修改的,则按规定输出。

思路:

遍历所有的密码,判断有没有这几个字符出现(注意:这里不能用str.find()来查找,如果有多个,需要全部改掉,find只记录第一个出现的位置)。

参考代码:

#include <iostream>
#include <vector>
#include <string>
using namespace std;
struct people{
    string name,password;
}user[1001];
string str="1l0O",str1="@L%o";
vector<int> m;
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        bool flag=false;
        cin>>user[i].name>>user[i].password;
        for(int j=0;j<user[i].password.length();j++){
            for(int k=0;k<4;k++){
                if(user[i].password[j]==str[k]){
                    user[i].password[j]=str1[k];
                    flag=true;
                }
            }
        }
        if(flag)m.push_back(i);
    }
    if(!m.empty()){
        printf("%d\n",m.size());
        for(int i=0;i<m.size();i++)
            cout<<user[m[i]].name<<" "<<user[m[i]].password<<endl;
    }else {
        printf("There %s %d %s and no account is modified\n"
               ,n==1?"is":"are",n,n==1?"account":"accounts");
    }
    return 0;
}

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值