【PAT甲级A1065】A+B and C (64bit) (20分)(c++)

1065 A+B and C (64bit) (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Given three integers A, B and C in [−2​63​​ ,2​63​​ ], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题意:

判断长整型数a+b>c?

思路:

当long long超出正限制是会显示负数(可以想象成环,正的不够了只能到负的上去凑),超出负限制时会显示正。(注意这里一定要定义一个long long的sum,直接用a+b来判断的话系统会将和自动分配一个适合的变量类型double)。

参考代码:

#include <cstdio>
int main() {
    int n;
    scanf("%d",&n);
    long long a,b,c,sum;
    for(int i=0;i<n;i++){
        scanf("%lld%lld%lld",&a,&b,&c);
        sum=a+b;
        printf("Case #%d: ",i+1);
        if(a>0&&b>0&&sum<=0)printf("true\n");
        else if(a<0&&b<0&&sum>=0)printf("false\n");
        else printf("%s\n",sum>c?"true":"false");
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值