【PAT甲级A1072】Gas Station (30分)(c++)

1072 Gas Station (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:200 ms
内存限制:64 MB

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​ ), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​ ), the number of roads connecting the houses and the gas stations; and D​S​​ , the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist 

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:
For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

题意:

有m个加油站和n个居民房,要求离加油站最近的居民房竟可能远,如果一样,则离其他加油站和居民房的平均距离尽可能小。

思路:

先求每个加油站为起点,到居民房和其他加油站的最短距离。然后在到n个居民房的最短距离中选择最近的,记录这个值。比较每个加油站记录的这个值,挑最大的。
用dijkstra计算起点到每个结点的最短距离,进行比较。读入的结点用字符串转整型,吧加油站的下标放在居民房之后即可。

参考代码:

#include <iostream>
#include <algorithm>
#include <string>

using namespace std;
const int maxn = 1020;
const int INF = 1e9;
int G[maxn][maxn] = {0}, d[maxn];
bool vis[maxn];
int n, m, k, ds, dis;

int stoint(string s) {
    int sum = 0;
    for (int i = 0; i < s.length(); i++) {
        if (s[i] == 'G')continue;
        sum = sum * 10 + s[i] - '0';
    }
    return s[0] == 'G' ? sum + n : sum;
}

void dij(int st) {
    fill(d, d + maxn, INF);
    fill(vis, vis + maxn, false);
    d[st] = 0;
    for (int i = 1; i <= n + m; i++) {
        int u = -1, MIN = INF;
        for (int j = 1; j <= m + n; j++) {
            if (!vis[j] && d[j] < MIN) {
                u = j;
                MIN = d[j];
            }
        }
        if (u == -1)return;
        vis[u] = true;
        for (int v = 1; v <= n + m; v++) {
            if (!vis[v] && G[u][v] != INF && d[u] + G[u][v] < d[v])
                d[v] = d[u] + G[u][v];
        }
    }
}

int main() {
    scanf("%d%d%d%d", &n, &m, &k, &ds);
    string s1, s2;
    fill(G[0], G[0] + maxn * maxn, INF);
    for (int i = 0; i < k; i++) {
        cin >> s1 >> s2 >> dis;
        int x = stoint(s1);
        int y = stoint(s2);
        G[x][y] = min(G[x][y], dis);
        G[y][x] = G[x][y];
    }
    int index = -1;
    double minavg, maxd = -1;
    for (int i = n + 1; i <= n + m; i++) {
        dij(i);
        double mind = INF, avg = 0;
        for (int j = 1; j <= n; j++) {
            if (d[j] > ds) {
                mind = -1;
                break;
            }
            mind = d[j] < mind ? d[j] : mind;
            avg += 1.0 * d[j];
        }
        if (mind == -1)continue;
        avg /= n;
        if (mind > maxd) {
            maxd = mind;
            index = i - n;
            minavg = avg;
        } else if (mind == maxd && avg < minavg) {
            index = i - n;
            minavg = avg;
        }
    }
    if (index == -1)printf("No Solution");
    else printf("G%d\n%.1f %.1f", index, maxd, minavg);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值